RAK 10701 TTN Gateway to Application

I am trying to set up the 10701 through a 7289C GW to TTN by following the TTN instructions in the RAK manuals (run through it multiple times to be sure).

I can see the 10701 uplink in the GW packet logger and in the TTN gateway Live Data and (EDIT) after correcting cluster locations/urls for my location can get the appliction showing some activity, However I never see any data come through and on the device itself it never shows any connections. It simply states joining and failed. Live data from device in TTN asw below

• arrow_downward 22:46:09 Downlink successfully transmitted Rx1 Delay 5
• arrow_upward 22:46:06 Forward join-accept to Application Server
• arrow_upward 22:46:06 Forward join-accept message
• arrow_upward 22:46:06 Receive join-accept message
• arrow_downward 22:46:06 Successfully scheduled join-accept for transmission on Gateway Server
• arrow_downward
22:46:06 Schedule join-accept for transmission on Gateway Server Rx1 Delay 5
• arrow_upward
22:46:04 Successfully processed join-request
• arrow_upward 22:46:04 Join-request to cluster-local Join Server succeeded
• link 22:46:04 Accept join-request
• arrow_upward 22:46:04 Send join-request to cluster-local Join Server Selected MAC version MAC_V1_0_3
• arrow_upward 22:46:04 Receive join-request

I have triple checked DevEUI AppEUI and AppKEY. All are as required. Latest firmware on the 10701 with band set to AU915, the GW to Region AU915-928 and the TTN GW frequency plan to AU_915_928_FSB_2, au1 cluster.

I have reread the manual so many times but cannot see where I am going wrong.

The 10701 is set to 20s TX int, DR2, Tx Power 1. It tries 8 times at 20 s intervals with message ‘failed’ on the deivce each time then finally stalls showing message ‘joining’.

This is all new to me so appreciate any advice!

Welcome to the forum @plam

In TTN, which subband did you choose when you setup the device for AU915?

Depending on the selected subband, you have to setup the RAK10701 to the same subband, which is possible by using the AT command AT+MASK ==> AT+MASK docs

For AU915 the default should be FSB2 (subband 2). Which is set with AT+MASK=0002

Thanks @beegee, yes I am using AU_915_928_FSB_2.

Also using wistoolbox rather than AT cmds. Active region under global settings is set to AU915. I assume that is equivalent? This also appears changeable via the device settings which shows AU915 also.

Just to be sure, can you use the console of WisToolBox and send AT+MASK=? to the device.
The subbands cannot be set through the UI of WisToolBox.

And check the log on the gateway if there are any errors listed that could show why the join accept is not sent to the device.

WisGate OS 2:

Old WisGate OS:

Great thanks @beegee. AT outputs as below which has got me to the next stage.

AT+MASK=00FF(single channel mode: 915400000)

The device now joins and ‘No of Gateway’ and RSSI data shows and TTN shows the location data.

Now I get ‘failed to send to webhook operation timed out’ in the app device live data. I guess that is related to the device not showing distance. I will recheck my webhook settings.


Thanks again!

Glad I could help.
Regarding the timeout from the back-end, that is out of our hands, as we are not providing or maintaining the back-end.

If the problem is not solving, you can as well use my Chirpstack tutorial with Datacake as an back-end. Just instead Chirpstack HTTP integration you setup the HTTP integration in TTN.

Thanks @beegee.

I will have a look at datacake, but given there is no guide for 10701/TTN/Datacake its probably beyond me.

Just to be clear what should be displaying on the TTN device live data. This is what I have from device startup for the 10701. Doesn’t show time out anymore but I get no distance on the device screen

Thanks again for your assistance,

And in the gateway

It is actually easier to connect Datacake to TTN than to Chirpstack.
In TTN, the Datacake integration is already pre-configured.

@beegee I am trying the datacake without luck but obviously the documentation doesn’t cover it. Can you confirm the following settings.

Do all Datacake listed payload parsers and decoders as shown for chirpstack apply when used in TTN withut modification?

Network server in DC??

“is_TTN” instead of "is_Chirpstack in “Fields” under config…??

IS_TTN Corect?

TTN Dakacake Webhook settings ??

HI @plam

(1) the decoder for Datacake should be able to get all required info from the data that TTN sends.

(2) selected network server in Datacake should be The Things Stack V3

(3) is_TTN is a flag that should be set in the parser when data from TTN was found, so in the Downlink configuration you should use “IS_TTN”

(4) for the TTN Datacake webhook settings, it looks correct. But it is a long time since I connected the Fieldtester over TTN.

Thanks @beegee,

I have made adjustments as best I can without luck. After two weeks of trying I think we are probably reaching a conclusion to return the product.

With disk91 being “out of our hands”, and “it is a long time since I connected it to TTN”, and the fact that the documentation is lacking in this regards, we are feeling that the advertised functionality of compatability with all LoraWAN and “shows min and max distance to gateways in range” cannot be acheived as readily as expected.

Unless you can direct me to any other updated/relevant documentation we’ll put this down to a learning experience.

Thanks again for you help.