RAK 11720 Breakout Board is not Compiling at all

Please include the following information, in order for us to help you as effectively as possible.

  • What product do you wish to discuss? RAK4631, RAK3372, RAK11200, RAK11310, RAK11722?
    RAK11720 Breakout_VB

  • What firmware are you using? (RUI3 or Arduino BSP or other IDE (e.g. STM32CubeIDE)?

Version: RUI_4.0.6_RAK11720

  • Computer OS? (MacOS, Linux, Windows)

  • How often does the problem happen?

I can able to use AT commands from UART0 but I cannot compile any of the examples. The error is below:

ModuleNotFoundError: No module named ‘Crypto’
exit status 1
Error compiling for board WisBlock Core RAK11720 Board.

I tried to burn the bootlader just like in the video but also it returns NullPointerException.
Then I tried to upload latest firmware from STM32CUBE but I could not connect the Module with the IDE. I tried both UART0 and UART1. Also tried with the 9600 and 115200 baud. In every case it return timeout for connection. However, in the 115200 baudrate I can send AT commands and get response from the module in Arduino Serial Monitor. What should I do?

Which version of the RUI3 BSP do you have installed?
Which example code are you trying to compile?

The RAK11720 does not have an STM microcontroller. It is based on the Ambiq Apollo3 MCU. You cannot create or upload firmware that was compiled with STM32Cube to it.

Option 1:
Use RUI3 for the RAK11720 to write your custom firmware (which you obviously tried)

Option 2:
Install the Ambiq Apollo3 SDK and write your custom firmware with this SDK.

Thank you for your quick response,
I will try both options and get back to you.