RAK 11720 not connecting to Jlink segger

Hello there,

I have a RAK11720 breakout board and i cant upload firmware anymore because the bootloader is running stock. So i bought a Jlink edu mini from segger to upload the firmware via SWD but it fails to connect. Iam using the following connections:


Jlink TO RAK11720
ground → ground
nReset → RST
Boot 0 → Gnd (tried also with vdd)

And the RAK11720 is powered by the RAKDAP1, further i using a common ground from RAKDAP1 to Jlink edu mini.

Iam unable to connect to the target and receive the error"trying to connect under reset". Like here below:

I tried to put the reset pin of the Jlink edu mini to ground with a pull down and also to VDD but nothing changes. I dont know how i can connect the RAK11720 to reset the firmware… Any help is welcome!

Kind regards,
Marnick Bijlsma

Welcome back to the forum @Marnick

Did you connect VTref of the Jlink to VDD of the RAK11720? At least my JLink needs that to know what the voltage levels are on the SWD interface.

Try to connect in addition nRESET to RST of the RAK11720.

I never connect SWO

This is for the RAK3172, but should be the same for RAK11720

Thankyou very much for your help,

I tried your schematic but i still receive the same error:

Btw: i have the 10 pins connector on jlink. Because TCK and TMS are switched compared to SWDIO and SWDCLK.

Do i only need the Segger J-Flash V7.96f or do i need another version. And are there important settings?

These are my settings:

And in the J-Link commander i receive this:

Kind regards,

Oh, that’s in error in my image.
TMS should go to SWDIO
TCK should go to SWCLK

Sorry for that.

This was also not the solution, do you have other ideas what could be the problem?

Can you check whether the Jlink edu mini is supporting the AMA3B1KK-KBR?
I am not sure (I have a full fleged Jlink) if the “education” versions are supporting all MCU’s

Other than that I am out of ideas if
you have proper 3.3V supply
all wires connections are made correct
no loose connections

As i can see the AMA3B1KK-KBR is supporting the edu jlink mini. Did you use jlink commander or only jlink flash?

I am always using JLink Flash. I never use the commander