RAK 13101 Not responding MQTT commands


I’m using the RAK13101. The module responds to any AT command included in the manufacturer manual. However, using the GSM MQTT application note won’t produce any response in the module. I’ve tried with different versions of the application note (from 1.0 to 1.2) but the module just won’t respond. The application note states that the MC20 gsm module is supported for MQTT commands.

I’m kinda lost at this point. The purpose of this application is secure communication SSL/TLS.

Thanks for the support.

Welcome to RAK forum @Giorgio_Hernandez ,

I am checking with the team about this issue. I have to confirm if the MC20 variant on RAK13101 supports MQTT. I’ll get back to you as soon as I get any useful info.

Hello, thanks for your answer.

Do you have any new information about this issue?

Hi @Giorgio_Hernandez ,

Our SW team is still looking at it. Btw, have you tried doing TCP connection? As you know MQTT protocol run via TCP so having this connection is a necessary.

You can try this sketch but you have to update info of your local telco company as well as the IP receiving endpoint.

Another thing you can try to check TCP connection is to try this integration guide we have for Ubidots - Sending data to Ubidots using WisBlock Ecosystem - Hackster.io

Hello guys

I don’t think the MC20 supports MQTT AT commands. In the GSM MQTT Application Note 1.3 document - section 1.1 Applicable Modules - the MC20 is not listed.


1 Like

Thank you for sharing this @felmue . It seems they remove MC20 support on the recent updates.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.