Rak 2247 raspberry pi4 newbie

Issue: im a newbie which is probably the first issue. I have installed sapian lite and then installed
https://github.com/RAKWireless/rak_common_for_gateway selecting the correct gateway 2247. then login via ssh to and sudo gateway-config and try to edit packet forwarder but unable. unable to browse using IP address:8080.

Setup:raspberry pi4


Details: Need some help trying to get the gateway running.

Thank you

Cross-site double post - please choose this or TTN forum.

Try this as pre-built image from 10 days ago:


Thanks very much, just giving it a go now

the image worked and have configured LAN and can ssh into no problems. in the edit packet forwarder I have added my gateway ID. I don’t have any configuration though for TTN which I assume I would need to add in? Is there any type of GUI with these devices to very logs/packets etc? Many Thanks

I haven’t tried this firmware - other Pi based ones from RAK usually ask if you want to connect to TTN.

You will need to register the gateway with TTN and ensure your gateway is pointing at the correct domain - see their instructions.

I’ve not seen any GUI for the logs - I generally use tail to watch the action for the very short amount of time I may be debugging - once gateways are working they tend to keep on going - I only look at the logs if I’m debugging a custom node.

its very odd but I am very new to this But it does not ask for my TTN gateway id of any other info so unsure how it will work without that.

TTN asks for the gateway EUI, it doesn’t give you one.

Check out their docs on setup: