RAK 2744C - how to disable WIFI (both AP and Client mode)


I would like to disable WLAN altogether on the gateway

Currently set in Wifi client mode (I also have a cellular and ethernet connection to access router)

RAK 2744C

For security purposes, I would like to disable the Wifi on boot and just use cellular/ethernet.

I tried doing this by disabling the service

systemctl disable dbus-fi.w1.wpa_supplicant1.service

but wifi still comes up. I notice there are some custom scripts called at start from /etc/rc.local but couldn’t find a simple way to disable wlan0 coming up.

Any advice on the most compatible method to prevent wlan0 starting?

I might figure out what wifi kernel driver is being used and remove/blacklist it.

You may want to research this question in a general pi / raspbian type of context.

Thanks for suggestion, I have disabled the kernel modules as follows:


blacklist brcmfmac
blacklist brcmutil

That prevents the wifi starting