RAK 3272S Breakout Board

I am using RAK3272S Breakout Board. On flashing with the default firmware RAK_3172_latest_final.hex, i am unable to upload arduino code on it. It says,
Device not in boot mode
Detecting baudrate
Detect Baud rate failed, cannot detect baud rate.
At commands are unresponsive

HI @nikhil ,

Does your RAK3272S Board still respond to AT commands? If not, you will not be able to use the RAK DFU Tool or WisToolBox. You have to use STM32CubeProgrammer as mentioned as a note in our FW update guide - RAK3172 Module Quick Start Guide | RAKwireless Documentation Center

I performed the FW by connecting Boot0 to GND using STM32… After this step, the response on the AT commands is like “box” characters. Even after changing the baud in Arduino Serial monitor, the response remains gibberish. And when i try to upload code, it says Detect Baud Failed. I have came across this issue on 4 boards including RAK3172 Evaluation Board and RAK3272-SiP.

Hi @nikhil ,

Did you upload the .hex file and not .bin? Also after successful upload, did you restart the device and disconnect the BOOT pin to VDD?

Yes I have tried these steps. But after uploading the firmware, the AT commands work only with the BOOTO pin connected to VDD. if disconnected it doesn’t work. Then afterwards, I get the “Detecting Baud rate fail” message if try uploading a code. This is happening with multiple boards that I’m trying on

Hi Nikhil,

The behavior you describe is not possible since when BOOT is connected to VDD and you powered up your board, the STM32 chip will go to its bootloader.

With regards to "Detecting Baud rate fail”,

  1. Do you use a custom RAK3172 board? Or RAK breakout/evaluation board?
  2. When you use STM32CubeProgrammer to updated .hex file successfully, did you remove the connection of BOOT to VDD then reset the device before trying AT commands?
  3. Is the baud rate 115200 when you did test?
  4. Do you have other boards that work?
  5. Can you share me the specific .hex you tried to upload?

So I tested on 3X RAK3172 Evaluation Boards breakout boards and custom boards as well. Out of these, two work: One evaluation and one custom. Same issue arises when I use the RAK3172-SIP board.
I am uploading custom RAK 3.4.11_E_final.hex and RAK 3.5.1_E_final.hex file using the stm32Cube Programmer for the RAK3172 boards. I am following the steps:
Connect VDD to BootO.
Reset.
Connect STM32Cube
Open File—>Download
Disconnect STM32Cube
Disconnect Boot0
Restart power, Reset
Try AT commands
Upload a script using arduino IDE.

So when I try using AT commands, i get random characters. I tried AT+RUN, ATZ, AT+ATM etc. I just get random characters as output. After pulling reset to ground once, the response to AT commands stops.

Hi @nikhil ,

If the breakout board is the only malfunctioning (assuming all are the same including uploaded firmware), the only difference I can think of on that board with the Evaluation board and custom board are:

  • USB-Serial used (not sure what you use on RAK3172 breakout board that is not working well)
  • The chip itself (could be damaged already)
1 Like