RAK 4631 Driver/Serial Problems

Issue: I have just recently bought a RAK4631 and a RAK19007 to use for my meshtastic project. When I try connecting them to my computer I am not able to mounted drive when they are in boot mode. Also, I can’t connect over serial at all to any of my boards. I have tried multiple usb cables, modules, and computers all with no luck.

If anyone knows some of the methods I can try to debug this issue that would be great. So far all of the form posts have not helped me get much further on this issue.

Let me know if there are any more details that I should post to help in finding a solution.



Welcome to RAK forum @RyanB ,

As I look at it, the port was detected correctly. What happens if you double click the reset button?

Also would there be chance that you order a wrong WisBlock Core? I looked on my RAK4631-R and we have the same VID and PID. You can validated if you have RUI3 firmware by sending basic AT command like AT or ATE.

Thanks for the Carl,

I believe that is the case but I know that there is a process to convert the bootloaders?

To answer the other question double tapping the rest seems to do nothing. I can get it into boot mode with serial commands.

I am new to Nordic Semi devices so I might be doing something wrong!

Thanks for the help so far.

Sorry for the being all over the place but I think I have got around most of the previous problems by using nRF Connect.

Right now I am trying to flash the Arduino bootloader but it is still not easy as my windows machines wont mount the drive for drag and drop. This is the guide I started from: Convert RAK4631-R to RAK4631 | Meshtastic

Here is the log from the farthest I have gone so far:

  1. Enter serial commands: AT, AT-BOOT
  2. Disconnect port from serial terminal
  3. Run adafruit-nrfutil.exe --verbose dfu serial --package rui3_nrf52840_bootloader_latest.zip --port COM21 -b 115200 --singlebank --touch 1200 in powershell
PS C:\rak> adafruit-nrfutil.exe --verbose dfu serial --package rui3_nrf52840_bootloader_latest.zip --port COM21 -b 115200 --singlebank --touch 1200
Upgrading target on COM21 with DFU package C:\rak\rui3_nrf52840_bootloader_latest.zip. Flow control is disabled, Single bank, Touch 1200
Touched serial port COM21
Opened serial port COM21
Starting DFU upgrade of type 2, SoftDevice size: 0, bootloader size: 36184, application size: 0
Sending DFU start packet
Timed out waiting for acknowledgement from device.
Sending DFU init packet

Failed to upgrade target. Error is: Attempting to use a port that is not open
Traceback (most recent call last):
  File "C:\Python311\Lib\site-packages\nordicsemi\__main__.py", line 296, in serial
  File "C:\Python311\Lib\site-packages\nordicsemi\dfu\dfu.py", line 232, in dfu_send_images
    self._dfu_send_image(HexType.BOOTLOADER, self.manifest.bootloader)
  File "C:\Python311\Lib\site-packages\nordicsemi\dfu\dfu.py", line 203, in _dfu_send_image
  File "C:\Python311\Lib\site-packages\nordicsemi\dfu\dfu_transport_serial.py", line 155, in send_init_packet
  File "C:\Python311\Lib\site-packages\nordicsemi\dfu\dfu_transport_serial.py", line 241, in send_packet
  File "C:\Python311\Lib\site-packages\serial\serialwin32.py", line 306, in write
    raise PortNotOpenError()
serial.serialutil.PortNotOpenError: Attempting to use a port that is not open

Possible causes:
- Selected Bootloader version does not match the one on Bluefruit device.
    Please upgrade the Bootloader or select correct version in Tools->Bootloader.
- Baud rate must be 115200, Flow control must be off.
- Target is not in DFU mode. Ground DFU pin and RESET and release both to enter DFU mode.

Hi @RyanB ,

Please use this guide for converting RAK4631-R to RAK4631.

However, on my last test, I am having issues (I am not sure if we have same case).

So when I converted my RAK4631-R, I used RAKDAP1 as shown in this guide Convert RAK4631-R to RAK4631 | Meshtastic

1 Like

I just followed these steps: Device Firmware Upgrade | RAKwireless Documentation Center and was able complete it successfully.

It looks like my issue was my smart card reader was blocking the serial access somehow so when I quit that program everything started working.

Just to confirm, you were able to convert RAK4631-R to RAK4631 via USB right?

What OS are you using?

Yes, I was able to convert using Win 11.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.