RAK 4631 RUI3 AT commands no response

Hello!

I’m using RAK4631 for my solution.
When I use AT commands via Serial Monitor in Arduino IDE i can see responses but when I use AT commands via code I can’t see any.
Are AT commands available through code in RUI3?

Welcome to the forum @frangier

What exactly do you mean with when I use AT commands via code?
Are you sending AT commands from another MCU over UART?

Assume your are using RUI3 with Arduino IDE, you use something like Serial.print(“AT+xxxx”)

Take a look at the RAKwireless Unified Interface V3 (RUI3) | RAKwireless Documentation Center, the RUI3 API section, you should use something like api.lorawan.appeui.get(buf, len);

Thank you for your replies and I apologise for the lack of sufficient information. Let me explain my case better.

I want to send an AT command from RAK 4631 to RAK 13101.
This can easily be done from the Arduino BSP using Serial1.println(“AT+XXX”);

When I tried to do this with the RUI3 BSP, I got no response on my Serial Monitor.
Also, when I tried to use Serial.println(“AT+XXX”); to get a response from the RAK4631, I also saw no response.