RAK 5205 serial command error

I have an AS923 RAK 5205 and I am using the recommended RAK Serial Port Tool. However, any AT command I sent only prompts an “ERROR: 86” message, which corresponds to “The device has not joined a LoRa network” based on the AT command manual.

I don’t have a gateway that supports AS923 currently, which is why I am trying to change the region of the RAK 5205 device using “at+set_config=lora:region:US915”

I am quite confused about why this is even happening because AT commands are simply serial commands and shouldn’t require the device to join a LoRa network. How can I debug this?
Thank you!

Welcome to RAK forum @lytzV :slight_smile:

Regarding your issue, no AT commands is accepted? Even at+version shows ERROR: 86?

Did you have a good reply even once or is it a consistent ERROR: 86 all the time since you got the device?

Have you tried to use a different computer? How about use a different serial terminal software?

  1. Correct. Even at+version.
  2. Consistent ERROR: 86 whenever I send an AT command
  3. I have also tried to write to serial port using pyserial and monitor using minicom, what other alternatives are there?

FYI, I have tried another device (in US915 region) on the same computer and the same software, and all AT commands work fine (even when it has not joined a LoRa network) @carlrowan

I am not sure what state the current FW is in but can you try to update the FW using this guide Quick Start Guide | RAKwireless Documentation Center?

I have done that as well : ( @carlrowan

What FW version you tried to upload? Via STM32CubeProg or via RAK DFU? Did you perform an erase first if you use STM32CubeProg?

If you erase the FW (no new FW uploaded yet) and you try to send AT command, did you receive any reply (just for sanity check but we should expect no reply since it is empty).

STM32CubeProg, and I did erase it before burning the image.
I tried your sanity test and the reply is empty as expected :slight_smile: (empty as in just empty spaces) @carlrowan

Also, when this device failed to join after 6 retries, it also prints ERROR: 99, which is not something I see on my other RAK 5205 device.

Really strange thing happening here :cry:

If I am on your case, next thing I’ll do is try to upload the RAK811 default FW and not RAK5205. Just to isolate if it is a RAK5205 FW related issue.

Regarding ERROR:99, it is failing to join but I am not sure if it is related to ERROR:86 (yet).

I uploaded a RAK811 firmware found here (https://downloads.rakwireless.com/LoRa/WisNode/Firmware/) and burned the hex file as well. Still the same ERROR: 86, so doesn’t seem like a RAK5205 FW issue. @carlrowan

For the RAK811 default firmware you should download it from here https://downloads.rakwireless.com/LoRa/RAK811/Firmware/

Hi, thanx for pointing it out, but I tried that as well. Still the same ERROR: 86, so doesn’t seem like a RAK5205 FW issue. @carlrowan @beegee