RAK 7200 stops sending data after some time

Issue: Stops sending data after few hours

Setup: OTAA, send interval 120s, auto send status true

Server: Chirpstack

Details: After you configure using RAK tool and test it, it sends for a while but stops sending automatically after 6-10 hours. Version Next time we reset or connect again to serial port and do at+join it will join again and starts sending. We thought it was send only on movement so set this command send_interval:1:120 . Immediately after it was sending every 2 min but then it just stopped. Is there a config mistake?

We only needed to connect to serial cable . There was no need for join command for it to wake up

The RAK7200 is a battery powered device, so once the battery is empty it stops working.

The send interval (2 minutes) can be changed with an AT command

Parameter Description
status Enable/disable the mechanism for sending data in intervals.
0: the device will not send data automatically.
1: the device will send data every ‘interval’ seconds.
interval Time in seconds. This parameter is only valid if ‘status’ is set to 1.

You can stop the automatic sending by setting <status> to 0 like

But the RAK7200 does not support to send a packet after movement was detected by the accelerometer :sob: So when you disable the automatic sending, you will not get any packet from the device.


We followed your advice and changed it to 3600 sec interval. It was working fine from Aug 6 till 10th. Then suddenly there was lot of error with frame counter and then its stopped sending.

Also it never sends GPS data in Cayenne Format

After lot of searching found this RUI_LoRa_node_payload_decoder/RUISensorDataDecoder_GPS6digitPrecison_for_ChirpStack.js at master · RAKWireless/RUI_LoRa_node_payload_decoder · GitHub
Also the status message always show 100% battery which must be wrong. Please help

Like last time connecting to cable made it start sending. Battery always shows 100% so could it be that battery is over or some other issue

Now that I used this decoder, data is coming like this
{“altitude”:"-14758702.1m",“latitude”:“133.93869°”,“longitude”:“355.860492°”,“magnetometer_y”:"-114.6μT",“magnetometer_z”:"-63.6μT"} which was better so trying to set to the other one. RUI_LoRa_node_payload_decoder/RUISensorDataDecoder_for_ChirpStack.js at master · RAKWireless/RUI_LoRa_node_payload_decoder · GitHub