RAK 831 Raspberry Pi Zero 915MHZ TTN not connected

Hi, I am trying to connect to TTN my gateway, I have the RAK 831 Developer Kit in 915mhz, i am using the raspberry pi zero w and the original rak to raspberry converter board, I have followed 2 tutorials, this one: https://github.com/ch2i/LoraGW-Setup/tree/15f56e03546c6c5885b58259db64c0fa10af1250
And the one that is in your page: https://downloads.rakwireless.com/en/LoRa/RAK831-Pilot-Gateway/Firmware/
Non has worked for me, I registered in TTN, but never seems to be connected :slight_smile:

I also registered my Json file in the Github repository.

I would like to know if someone can help me to connect it to TTN, IΒ΄ve been reading and I think that is a problem with the Reset Pin or with the 915mhz band.

Thanks in advance guys!!!

I’ve tried this one: https://github.com/RAKWireless/rak_common_for_gateway
and it doesn’t work either, I went to sudo gateway-config and select the setup of the Rak gateway to TTN and US902_928 channel plan, but it never shows up like Status: not connected in the TTN’s gateway overview.

Hi @sebasretes,

What firmware version are you using?


1 Like

I am using the Raspbian_OS_V2.9.1 from this https://downloads.rakwireless.com/en/LoRa/RAK831-Pilot-Gateway/Firmware/

Hi @sebasretes,

Can you check in your local/Global_config.json file what Gateway EUI you have and if it matches the one in TTN ?


1 Like

Hi @Hobo
I checked it and it seems like it is not configured.
Here is a capture:

I am doing it via WiFi with my raspberry pi zero w.

Do I have to edit the file global_config.json manually, or do I have to edit something in the raspbi configuration?

Hi @sebasretes,

Can you also post the local_conf.json. My buddy @velev should be able to help once we check the other file too.


1 Like

yes of course, here is it @Hobo

I entered by using this: nano /opt/ttn-gateway/packet_forwarder/lora_pkt_fwd/local_conf.json

Hello @Hobo.

Do you only need this file?

Hi @sebasretes,

It is because of gateway ID.
Normally, Our firmware which you download from RAK website is used for RPi with eth0, and the gateway ID which you see in the loacl_config.json will generate automatically based on eth0 MAC address. The problem is there is no eth0 on your RPi zero, so the gateway ID can not be generate correctly.
Now, you can do as follow:

  1. Open the folder </opt/ttn-gateway/packet_forwarder/lora_pkt_fwd> of your RPi zero;
  2. Rename set_eui.sh and update_gwid.sh files to another name;
  3. Open the local_config.json and modify the gateway ID to the one you register in TTN.
  4. Restart you RPi.

OK, now, if the network from your RPi and TTN is fine, you should see the status on TTN is β€œconnected”.
Just try.

1 Like

Hello again.

I did some changes in /opt/ttn-gateway/packet_forwarder/lora_pkt_fwd/update_gwid.sh
I change this:
GWID_BEGIN=$(ip link show eth0 | awk β€˜/ether/ {print $2}’ | awk -F: β€˜{print $1$2$3}’)
GWID_END=$(ip link show eth0 | awk β€˜/ether/ {print $2}’ | awk -F: β€˜{print $4$5$6}’)

for this:
GWID_BEGIN=$(ip link show wlan0 | awk β€˜/ether/ {print $2}’ | awk -F: β€˜{print $1$2$3}’)
GWID_END=$(ip link show wlan0 | awk β€˜/ether/ {print $2}’ | awk -F: β€˜{print $4$5$6}’)

Basically just eth0 to wlan0.

After that I edited /opt/ttn-gateway/packet_forwarder/lora_pkt_fwd/local_conf.json
Changed the gateway_ID to the one that I have in TTN.

After that, my gateway seems to be connected:

After reading some @velev replies ( in this thread RAK2245 pi hat + Rpi zero w)
I was able to solve the problem.

Thanks for your help guys, you are amazing!

I am going to keep working to connect some nodes.

Hello @Fomi.
Thanks for your reply too.
You exactly described the solution.