Rak-gateway login: problem

I have installed raspberryPi Buster Lite on SD card using a RAK-831 gateway and RAK2245_based_on_Raspbian_OS_for_RPI3_V4.1.0_20191202.img
I change the password in RaspberryPi.

What username and password does rak-gateway login: use ? I have used Pi password and Admin etc but I can’t login in to rak-gateway.

ssh’s default username/password is "pi/raspberry".

chirpstack’s default username/password is "admin/admin".

I tried both usernames, passwords and rak-gateway login: will not accept them.

When I Install Buster-Lite everything works ok ,login, do SSH and make changes, but when I install RAK-831 gateway and RAK2245_based_on_Raspbian_OS_for_RPI3_V4.1.0_20191202.img then reboot Pi , and it comes up with the rak-gateway login: and won’t accept any uaername or password.

Is your Raspberry Pi model 3 or 4?

The firmware RAK2245_based_on_Raspbian_OS_for_RPI3_V4.1.0_20191202.img you use is only for Raspberry Pi 3.

For rak’s Raspberry Pi firmware, the default IP of eth0 is

I’m using a RaspberryPi 3B.
But why wouldn’t it accept the pi, raspberry or admin, admin as username:password ?

Raspi 3B+ ,I tried to ping and can’t REACH IP
In Chrome I tried and can’t FIND

I can ping , My Router

In Pi 3B+ , Raspi Buster-Lite from my PC I could connect to the pi doing a ssh [email protected]

So something in firmware ; RAK2245_based_on_Raspbian_OS_for_RPI3_V4.1.0_20191202.img
But in rak-gateway setup I can’t login or do anything.

Hi. If yor are using RAK Image for RPi and want to connect via ethernet you have to connect your PC to RPi directly with patch cable. Then set your PC IP to something is same network like PIs - - for example. Then you can ping and SSH to
You also can connect to RPi WiFi AP. You will see wireless network with the name RAKwireles_XXX , passowrd is rakwireless. Then the IP is

Then the login is default: “pi” for username and “raspberry” for password.

my first time to setup a rak-gateway.
Do you install a SD card with RaspberryPi Buster-lite first and then RAK2245_based_on_Raspbian_OS_for_RPI3_V4.1.0_20191202.img second ?

firmware ; RAK2245_based_on_Raspbian_OS_for_RPI3_V4.1.0_20191202.img

I have finally got rak-gateway setup, i was doing the installation wrong I got everything setup except doing ssh, I want to change my POE ethernet connection to [email protected]. , My gateway Router is , My PC is set to I have changed the Host to rak-gateway on the pi.

What is the name of “config” in the rak-gateway setup. I have searched all over the Internet on how to do this, but with no luck. I guess I’m using the wrong search info.

Doing raspi-config I enabled ssh, 2c, spi

If I do sudo ifconfig eth0 netmask on the rak-gateway it changes the eth0 to
If I do a reboot it changes eth0 back to

And the same if I do a sudo passwd, It changes password, but if I reboot it changes it back to default “raspberry” .

What am I not doing right ?

If you use rak’s gateway firmware, after logging in to the gateway via ssh, you can use sudo gateway-config to modify the IP address of eth0.

On all linux operating systems, what you modify with the "sudo ifconfig eth0 netmask" command will not work after restart.