Rak-gateway login

installed Pasp Pi with Etcher, Installed Raspi first and Etcher RAK2245&RAK831_based_on_Raspbian_OS_V2.8R_20190509.img second, putting SD card in Raspberry Pi 3+ and booted-up and stopped at:
rak-gateway login, What is the gateway User and Password ? Checked all over Internet can’t find User, Password to rak-gateway.
How do I get into Rasp-Pi to setup Password and SSH ?

It does not go into Rasp Pi OS first is this normal ?

Hi @mickey,

Did you follow the instructions here:
http://docs.rakwireless.com/en/LoRa/RAK831-Pilot-Gateway/Application%20Notes/Get_Start_with_RAK2245&RAK831_RPi_LoRa_Gateway.pdf

If not I suggest you familiarize yourself with the document. I believe what you are looking is at page 6.

Regards

Thanks for that, I never seen that .pdf.

I don’t use Putty , I use straight SSH on Linux

On Ethernet cable connection I use 192.168.10.10 and I’m having problems of connecting to the Internet on RaspPI

but ssh is working fine on my Linux PC. I can’t get nmap to install on RaspPi

On the RaspPi /etc/resolv.conf shows nameserver 127.0.0.1, should it not be nameserver 192.168.10.10 ?

I have done a nano /etc/resolv.conf and change the nameserver to 192.168.10.10 but when I reboot it changes it back to 127.0.0.1.

“installed Pasp Pi with Etcher, Installed Raspi first and Etcher RAK2245&RAK831_based_on_Raspbian_OS_V2.8R_20190509.img second”
1.You only need to install RAK2245&RAK831_based_on_Raspbian_OS_V2.8R_20190509.img, no need to install Raspi
2.The default username is “pi”, and the default password is “raspberry”.
3.In the Raspberry Pi, after the file /etc/resolv.conf is changed, if the operating system is restarted, the file /etc/resolv.conf will automatically be restored to the default.
4.The gateway has two connection methods, refer to the following picture:

I have similar a looking problem.
On correcting resolv.conf to point at my router on the LAN, names are resolving, but I still can’t ping addresses on the internet (“Destination Host Unreachable”)

My issue may be related to:
1/ I’m using a RasPi2. Is that supported? (I wish to connect via Ethernet)

2/ I downloaded raspian stretch lite
2a/ then installed the gateway using the instructions here:
https://github.com/RAKWireless/rak_common_for_gateway

Thanks in advance, W

Hi @waynemcl,

Did you do the last step?

step5 : Wait a moment and the installation is complete.If your gateway uses a wired connection, please reconfigure the LAN’s IP address using “sudo gateway-config” after the installation is complete.

Regards
Vladislav

Thank you for checking in. I did do this, and the device is accessible by ssh on the local 10.0.0…x network.
I rebooted, and did it again, but the network can’t access the outside world (breaking apt, ping etc).

Hi @waynemcl,

What interface are you using:
Ethernet Port
Wi-Fi

Regards
Vladislav

Using Ethernet. Thanks.
BTW: I have changed to RasPi3 Model 3B+, same issue

Hi @waynemcl,

I apologize if the questions seems dumb, but did you manually configure the IP Address of the Ethernet interface and the Outgoing Gateway (probably your router) IP Address in the configuration dialog, point 6.
The one you get via the sudo gateway-config command?

Regards
Vladislav

Thank you for carefully checking.
I did not put my LAN router address in the box labelled “LoraServer_IP” (point 6.2 in the "Get Start… doc)
(… because I was intending to run up a server on localhost). Now I understand that’s what is needed for default setup, I have tried it, and it works.
The RasPi with RAK gateway setup now does DHCP client on the LAN, can ping the 'net, and apt works.
Thank you for your time. This was most helpful.