RAK10701-H mapper won’t turn on after firmware update

I did a firmware update on my new RAK10701-H field mapper using the WisToolBox Android app and it said the update was successful but now I cannot turn it back on.

I tried to do a firmware update using the Windows version of the WisToolBox software but does not update.


Welcome to RAK forum @Neil ,

Can you please confirm that you used the firmware here when you updated using WisToolBox and not the default firmware for RAK4630?

Also, when you updated the firmware, is the unit battery condition good (I mean is it charged and not low batt?)

In the Android app I think it used the default 4630 firmware which it said it uploaded.

I tried the firmware in your link by the windows software.


It was also charged.

I did notice that it shut off before the update was finished but the App said it was successful

Hi @carlrowan & @Neil
I have the same issue, is there any way to solve this issue?

Welcome to RAK forum @faliqulamin ,

May I know on what firmware version your device is? Btw, you used WisToolBox to update to v1.1.2 right? Also, just to confirm, you have no issue on the device before the update?

Hi @carlrowan
Thank you for the response, I used WisToolBox for android with version 1.21.7, and i forget the firmware version. Looks like no issue when i received this RAK10701-P, but my RAK10701-P can’t join to my Gateway/TTN, and i initiate to upgrade the firmware. and my RAK10701-P is on charging when i upgrade the firmware.

i have another question :
I order RAK10701-P with Frequency AS923 but it’s come with US915, we can configure the Frequency AS923, rigth?

Hi @faliqulamin ,

Can you please try to connect it to PC via USB C port then use WisToolBox desktop app detect it? If it is detected you can try to initiate another FW update directly via PC.

Yes, you can configure it from AS923 to US915 and vice versa via the touchscreen interface.

Hi @carlrowan ,
from the beginning i received this RAK10701-P, wistoolbox Desktop (ver. 1.4.3) always failed to detect my RAK10701-P, this way i use Wistoolbox for android.
and until now, the COM PORT still detected. but can’t detect my RAK10701-P.

Hi @faliqulamin ,

Some thoughts I have:

  1. Update the WisToolBox to latest one v1.4.4.
  2. Look for Windows PC if you are using Linux/macOS. Or try to check with other PC with latest WisToolBox if it will be detected.
  3. Check using terminal sofware like realterm, coolterm, etc., if AT commands is still recognized.

Hi @carlrowan
Thank you for the advice, I successfully bring back my device online again.
and currently i can join my TTN server, but i can see RSSI information on the screen of my device. any advice how to get the RSSI level?

Good news it is working again. Can you please share what went wrong? Could be a learning experience for me and for other users.

It appears to me that there is no successful uplink yet. Do you see any data in TTN? Also, were you able to setup the integration with disk91 server?

In addition, in the lower left, there is no Lat and Long values, this means the device will not send uplinks since GPS fix to satellite is needed. No Lat/Long values means your GPS cannot find the satellites. What you can do is force uplink by doubleclick on the button. We will release update in the future that works indoor as well. But for now, to estimate the distance of the device to the gateway, a GPS fix is needed.