RAK11200 Download Mode


I recently received a RAK11200 with a RAK5005-O base and am trying to upload a simple arduino sketch to it. Ive grounded the BOOT0 pin on the 5005-O and pressed the reset button but my computer still doesnt recognize the board. Ive followed the instructions on the quickstart page to the T and it is still not working. Ive swapped out RAK11200, RAK5005-O, The wire I pull the pin low with, the cable that connects to the computer, heck, even the screws!

Thanks in advance!

Hello @J.H welcome to the forum.

A few questions:

  • If you plug in the WisBlock with the USB cable to the PC, does the PC recognize the RAK11200 as USB UART?
    • if yes, did you try to set the upload port in Arduino IDE to that COM port
    • if no, did you try different USB cable and different USB port?
    • if no, is the red LED on the WisBlock lighting up?
  • What IDE are you using?
  • What operating system are you using?
  • Did you try to keep the Boot0 pin grounded all the time while trying to upload the code?
1 Like

Hello beegee,

Thanks for your reply. To your questions:

  • No it does not and I have tried several USB cables and the red light is lighting up on the RAK5005-O board.
  • I am using the latest arduino build
  • Win10
  • Yes I have with no result


Thanks for the answers. The problem is then related to the USB connection, because Windows should at least give you BEEP or ask for installation of drivers.

The USB chip is separate from the ESP32 on the RAK11200 and is directly wired to the USB connector. But I don’t think that there is a HW problem with two RAK5005-O and two RAK11200.

On new RAK5005-O it is sometimes difficult to push the USB cable complete into the USB connector. The power supply (Red LED) is connected, but the D+ and D- pins are not. That’s a problem I experienced by myself before.

Can you check if the USB cable is really complete pushed into the WisBlock Connector.

1 Like

Hello Beegee,

I do get a BEEP from windows when I plug it in and I looked and it is connected under Other Devices (See image below).
Are there any drivers I can manually install?

It should install automatically.

Try the following
Select Update Driver from where you took above screenshot
On the next screen select Browse my computer for drivers

Then select Let me pick from a list of available drivers on my computer

If it shows USB Serial Device, select this driver, if not continue
Uncheck Show compatible hardware
Scroll down to Microsoft then select USB Serial Device

Then click Next to install that driver.

1 Like

Hello Beegee,

Ive installed the driver (still strange) but its now connected via COM11!

When I go to upload a sketch after grounding BOOT0 while pressing reset I still am getting an error:

Connect the RAK11200 and wait for the COM port to be available.
In Arduino IDE select the correct COM port and then open the Serial Monitor. Make sure it is set to 115200 Baud.
Ground Boot0, then press the reset button of the RAK11200
You should see the following text in the Serial Monitor:

If you see this text, close the Serial Monitor and try to upload your sketch.

1 Like

Here is what I am seeing:

That looks strange.
Did you reboot the computer after the driver was installed (just in case?)

1 Like

Hello, I just did and got the same result. When I fire up the serial monitor I do get the error message:

Error while setting serial port parameters: 115,200 N 8 1

Update: I tried it also on my other computer with a different board and got the same result. Is it possible the cores sent were faulty?

The modules are all tested in the production, so there should be no faulty module going out to customers.

The errors you get (COM port not detected, no automatic driver installation, Error setting COM port baud rate) are weird. I experienced some of them, but they could be resolved easily.

You said you changed USB cables, did you just change between USB cables that came with the modules or did you try another one as well?

Can you send me some images of the modules
RAK11200 unmounted top and bottom
RAK11200 mounted on the RAK5005-O angled top view

I did try swapping the 11200 with my 4631 and it worked fine for code upload and serial monitoring. I tried different usb’s than the ones shipped with it as well with no luck.

Ill have to send them in three different messages since I am a new member. Let me know if there are other pictures youd like me to send.

Ok, again, I see nothing really strange. That the RAK4631 works on the same Base boards shows that at least they are ok and the cable connection is ok.

If you are ok, I want to try one more thing.
Can you download the Espressif Download tool from Espressif

Unzip the tool and start flash_download_tool.exe
In the first window, select ESP32 and Work Mode Developer

Connect your ESP32 and make sure it is in Download Mode (Boot0 grounded)

In the next window select (1) the COM port the ESP32 is connected to and then (2) push the Start button.

If the ESP32 is not defect, it should show now some information:

Here is what I am getting after I press start and let it run:

I have 4 more at home and will test them with this in a bit.

They are all giving this result. What steps do you recommend next?

If there would be one of your 5 RAK11200 that do not work, I would think about a HW problem. But all 5 RAK11200 with the same problem is something I can’t believe.

You said you followed the docs, but just to make sure, can you confirm you connect these two pins before you try to flash: