Rak11300 - Error while uploading the sketch

I’m having the error “An error occurred while uploading the sketch” every time I try to upload a sketch to my Rak11300.
I have “show verbose output during: compilation and upload” but no further info are displayed.

This happens with all the examples and even using an empty “new project”.

I’ve followed this guide Installation of Board Support Package in Arduino IDE | RAKwireless Documentation Center and also tried to update the firmware as suggested there.

Any suggestion? What can I do?

I’m using Arduino IDE but also tried using Platform IO. I’ve tried both Ubuntu and Windows 10.

Hello. What happens if you just try to verify and compile the sketch? Is the compilation successful? Or has there been also an error occurred during compilation?

Untitled

Only compiling I have no errors

  1. What version of RAK11300 RP2040 BSP are you using? Is it the latest version?
  2. Can you send a snip pic or screenshot of the output error in your Arduino IDE. Something like this:

image

  1. Does your RAK11300 work before? or is it your first time using or trying the RAK11300?