RAK19007 port not detected

I have a RAK4631 mounted on RAK19007 but when connected to my PC, port is not detected USB device not recognized, malfunctioned.
How to troubleshoot it?

Hello Divya,

Did you try different USB cable and different USB port on your computer?
Are you connecting directly to the computer or through an USB hub? If you are using an USB hub, try to connect directly to the computer instead.

Is the red LED on the RAK19007 lighting up or at least flickering?

Tried different usb cable, different usb port, connected it directly to the computer no usb hub used, tried in a different computer nothing worked.
The red led is glowing.

Do you have any other WisBlock Base Boards to test?

No, I don’t have any other WisBlock Base board to test

Was it a starter-kit or did you buy the WisBlock Core and the WisBlock Base Board separate?

And no offence, but is the Core module mounted correct on the WisBlock Base Board?

Bought it separately & the module is mounted correctly as shown in the figure

Looks like either the USB connector on the Base Board is defect or the WisBlock Core module has a problem.

Did you buy directly from RAK or from a reseller?
If you bought from RAK store, please send an email to [email protected] and ask for support.
If you bought from a reseller, contact your shop.