RAK1906 Temp/Hum. sensor dead?


I have a RAK3172 with a RAK-1906 and RAK-12047 sensors modules. At first I loaded some demo program from RakWireless and it was showing at bootup in console presence of both sensors.
Then the RAK-1906 disappeared from system without any reason (no change on the board). I tried to move the RAK-1906 board in an other slot of the Wisblock board but no changes :frowning:
Defective module ? Something to try ?

I tried also with my own basic code but same, module is invisible :frowning:



#include "rak1906.h"
rak1906 rak1906;
float Temperature;
float Humidity;

void setup()
  pinMode(LED_BLUE, OUTPUT);
  digitalWrite(LED_BLUE, HIGH);
  Wire.begin(); // Begin function for I2C
  rak1906.init();//Start rak1901

void loop()
  // put your main code here, to run repeatedly:
  digitalWrite(LED_BLUE, HIGH);
  digitalWrite(LED_BLUE, LOW);
  if (rak1906.update()) {
    Temperature = rak1906.temperature();
    Humidity = rak1906.humidity();
    } else {
    Serial.println("Please plug in the sensor RAK1906 and Reboot");
  Serial.printf("Temperature = %.2f%°C\r\n", Temperature);
  Serial.printf("Humidity = %.2f%%\r\n", Humidity);
1 Like

Hi, any updates about situation?

nope as I didn’t get time so far to dig in to find out the problem :frowning:

1 Like