RAK2171 WisNode Trackit Registration Problem

Issue: I am trying to register some new RAK2171 Tracking Devices with the IoS app, in LoRaWAN mode. I have a RAK7258 LoRaWAN Gateway and have tried 1.3.1 and 1.3.3 firmware.

Setup:IoS App; RAK2171; RAK 7258 Indoor LoRa Gateway

Server: Network Server built in to gateway.

Details: I receive an error message in the IoS app “Gateway version needs WinGateOS_1.3.1_RAK or above. Enter the correct user name or password”.

I am using root, root as Gateway Sign In. The LoRaWAN gateway is working fine and is running the Network Server locally. I can login to the interface with those credentials.

The iPhone is connected to the WiFi SSID established by the gateway.

What’s this issue here? The version is correct and the credentials are correct.

Hi Pat,

I have exactly the same with its Android app. Have you received an answer already? Did you manage to solve the problem?

Best wishes,
Addy de Jongh

No reply, and still not resolved, I’m afraid!

Hi Pat,

I will write them an e-mail about it.

Best wishes,
Addy

Hi @patmolloy / @3dotter1 ,

Sorry that no one reaches you yet, in the forum.

Can you try to update the gateway to the latest WisGateOS1.3.3 from here: https://downloads.rakwireless.com/LoRa/WisGateOS/WisGateOS_V1.3.3.zip

Download the latest TrackIt app and update the TrackIt device to the latest firmware.

Then try again.

Hi Fernando,

As you can see I am not the only one experiencing this problem. Pat Molloy also.

I have contact with Todor Velev about the same issue as well. He asked me to send the Wisnode Trackit app log. See attachment for that.

I did exactly as you said and the problem keeps on being the same. See the screenshot about what the app shows me. Striking for me is that my Gateway shows after upgrading it with the firmware from your link above:
Firmware Version 1.3.3_RAK b100, but that the app wants to see: WisGateOS_1.3.1_RAK or above. The names of the firmware versions in my RAK7249 Gateway and the one mentioned in the app do not match.

So the bug has still not been solved. And I am sure I did the right things, exactly as you instructed me.

Nasty problem!

Please help!

Best wishes,
Addy

(Attachment 2022-07-12_db600aa7c0533903_TrackIt.log is missing)

Hi @3dotter1 . Yeah, a nasty problem. Do you have a ticket number for this? If not, please just write a mail to [email protected] and please include in CC to:

todor.velev
fernando.hernandez

Using the ticket way, we can be sure that your concerns will be addressed in a timely manner and with good quality.

I look for giving you a solution to this problem ASAP.

Hello Fernando and Pat,

By e-mail I got this answer from Todor:

Make a factory reset of the gateway: (System → Backup/Flash Firmware - > Reset to defaults) and then try to connect the TrackIt app with the GW WiFi AP and add the TrackIt.

It worked for me! :slight_smile: But my password was reset to “root” again. I can now add the wisnode Trackit trackers to my RAK7249 GateWay.

But what has been the bug?

And after this step how I can make my tracking data visible on any dashboard (e.g. through TTN, Helium or local Chirpstack)? Does the RAK7249 have its own embedded Chirpstack?

I’ll give it a go!

Pat ~Mobile~ iPhone 13 Pro Max

Hi, @3dotter1. Great news and congrats.

@patmolloy: Please confirm if it works for you also.

In regards to the bug, really I don’t know. I think it could be related to the normal software development lifecycle (you know, continuous delivery of updates among the the ecosystem members, for this case RAK and iOS).

In regards to making tracking data visible on a dashboard, it is needed to clarify that there are two different layers of software involved.

1- A LoRaWAN Network Server (LNS). You could choose one among several options.
2- A data visualization platform. You could choose one among several options.

The data from the end device goes first to the LNS and then to the data visualization platform.

However for the specific case of the TrackIt device you have the option of using the app on your cellphone as a visualization tool and the embedded LNS on the WisGate Edge by means of LoRaWAN mode.

The documentation also includes an example of using Helium as LNS and Datacake as a visualization tool.

Please follow the instructions in:

Also worked for me … I had to try a few times in the TrackIT to add, but eventually, I added two trackers successfully. Upon a successful add, the app terminates (crashes) abruptly … but the add is successful!

Would you share please the logs from the TrackIt app?

If you are using iOS, it is just a matter of request support from the App.

If using Android, the logs are located in the folder: Android folder → data → com.rak.wisnodetrackit → files → log .

Awaiting your response,