RAK2245 gateway stops connecting to WiFi, also Problem while flashing RAK2245 firmware in LPWAN gateway


I flashed RAK2245 image file in LPWAN Gateway, and configure it, it started connected to WiFi and started receiving lora packets from end node and sent/receive from TTN server as well. After some period it stops connecting same WiFi. So I formatted the SD card and tried to put back new gateway firmware image file in SD card. But I’m not able to flash it saying error–>Something went wrong. If it is a compressed image, please check that the archive is not corrupted.
User did not grant permission.

Any solution for this. I tried to run application as administrator as well but showing same error.

Hei @baba_blacksheep ,

This seems as a permissions issue. Running the Balena tools as an administrator seems to solve it for other Balena users with a similar problem, however not in your case.
Try to enable control folder access:
As for the gateway issue itself, it seems unlikely that the gateway Wi-Fi failed, could it be a local issue with your network?
Once the Balena issue is resolved and you connect the gateway again, keep the following link handy as it gives you a procedure to reset the gateway to AP mode so you can access it again in case the Wi-Fi client fails.
Try what I have suggested and give us feedback.


@Hobo reflashed firmware in RAK2245. After powered up gateway, after 3 to 5 minutes access point Rakwireless_XXXX shows. I’m able to connect to to gateway using ssh but connection went inactive after some time before I can connect gateway to wifi.

Access point name shows Rakwireless_XXXX

Can you expand on “went inactive” - if the Pi is powered from a decent (minimum 2A) power supply it should just stay online …

went inactive–got stuck (not able to process)

Solved. it was permission issue, due current antivirus in PC user was not getting permission. Running the Balena tools as an administrator seems to solve.

@nmcc @Hobo
access point now showing as Rakwireless_F223, Looks solved but I’m getting now new error while connecting RAK2245 gateway to SSID

Error–> Gateway-config: cannot communicate with wpa_supplicant


  1. connect PC to the device’s AP (initially it is in AP mode).

  2. ssh to the device, run gateway-config, change to client mode.

3. before reboot, configure the ssid and password etc. so that the device can connect to another wifi hotspot.

so when click on add new SSID it shows

So I checked wpa_supplicant_conf file

after I edited this file to

and try to add new ssid but it showing same error as (procedure client mode active,add ssid)

I’d sooooo definitely do it the other way round - telling it to be a client without giving it client details may have issues, particularly as it won’t know what region to use.

If you put an empty file in the boot volume called rak_ap it will let you back in again if you’ve ended up rebooting, see:


Created rak_ap file successfully in boot folder. Inserted sd card in RAK2245 gateway and powered the gateway. But now it not showing as wireless access point.

I’m not sure what the effects on editing the files manually would be on the restore to AP mode.

Can you put a monitor & keyboard on to the Pi and just install at the command line directly - it may be requiring an apt update. Or there may be something going on with the wifi stack …

@nmcc @Hobo just removed SD card, formatted it and flashed new gateway firmware in it. Created new rak_ap file as well.(not editing files manually) When try to connect with with wifi it showing same error “could not communicate with wpa_supplicant”.

Please stop combining solutions - they complicate the matter and could cause things to not work in a different way.

Did you do an apt update/upgrade before you tried the install?