RAK2245 No data to TTN

I can get the device to appear as active on TTN console, but cant get it to send data. Using the RAK2245_Latest_Firmware image flashed directly to SD card.

Also, how do disable using GPS?

Setup: RAK2245 HAT on Pi B+ from Adafruit, no GPS



Hei @Odenis ,

Can’t get the Gateway to send data where? Are you trying to send a downlink to one of your nodes ?


@Hobo Im not trying to get the gateway to send data anymore, that comment was 7months ago. Now im trying to disable the GPS - I do not have a GPS antenna for it. The documentation states not plugging in a GPS antenna could damage it, so Im trying to turn it off.

Ive found two spots:

  1. gateway-config file at bottom has fake_gps = false — can I just set this to true to disable?
  2. Pin 35 (GPIO19) is stated as being GPS Module standby PIN in the pin definition. I could set GPIO19 to low via config.txt

Hei @Odenis

  1. The RAK2245 should come with a GPS antenna included.
  2. There is actually a parameter that is for the GPS itself
    /* gps enable */
    gps: true,
    gps_tty_path: /dev/i2c-1,
    fake_gps: false,
    ref_latitude: 10,
    ref_longitude: 20,
    ref_altitude: -1

The code part is from the global_conf.json file.
You can turn it off by setting it to ‘false’, than you can chose to have it as false and enter coordinates manually.


@Hobo thank you for your reply
The device did not (got secondhand). The config file does not have the gps: true in it, i will add as false to disable.

I was editing fake_gps to true, but will change that back to false and add gps specifically.

thank you!

@Hobo would it also make sense to pull the pin35 down in the pi config?

Hi @Odenis ,

The json alone should work, try this first for now. As for having it second hand, you can always download a fresh firmware image of ours it should be an exact copy of what I referenced, in case you get lost:


@Hobo This is using that image, hence the question.
I added “gps”: false
under /* gps enable */