RAK2245 Not Seen in ChirpStack

Issue: RAK 2245 is not seen in ChirpStack Application Server despite following all steps outlined in the RAK 2245 Quick Start Guide. I’m currently attempting to use the built-in ChirpStack, but am receiving “Last Seen at: Never”

I am fairly new to RAK/LoRa/ChirpStack, so I am not sure what to do in the way of troubleshooting. I can successfully ping google.com, so I don’t believe my internet connection is the issue.

Setup: RAK2245

Server: RaspBerry Pi 3B+ w/ latest RAK2245 firmware installed

  • Output from sudo gateway-version sans EUI
    Raspberry Pi 3 Model B Rev 1.2, OS “10 (buster)”, 4.19.97-v7+.
    RAKWireless gateway RAK7243 no LTE version 4.2.5R install from firmware.

Because I am a new user I cannot embed more than one media post, but I can post my log outputs for the ChirpStack Application Server, Network Server, and Gateway Bridge in the replies (nothing appears abnormal to me)

I can provide additional information if needed/desired, any help would be greatly appreciated!

Hello Matt,

Might sounds stupid, but I want to make sure that the gateway is pointed to the build-in ChirpStack.
Can you check that in the sudo gateway-config command (Setup RAK Gateway Channel Plan). Server is ChirpStack must be selected:

The Application and Network Servers seem to be working (based on the logs and that you can access the ChirpStack UI).

Hi Martin,

Not stupid at all, I confirmed that ChirpStack is the Server Plan (gateway is still not seen)
Server_IP is (localhost)

Just to add some more possibly helpful information, after performing “sudo gateway-config” I went into Option 4, “Edit packet-forwarder config”. This took me to lora_pkt_fwd/global_conf.json and I noticed that under gateway_conf, gateway_ID was set to all 0’s and not my Gateway EUI (local_conf.json also exists but only contains the Gateway EUI, no other information). I changed that value to my Gateway EUI, restarted the packet forwarder, performed a reboot, but still did not see any change in the “Last seen at” status. I took a look in daemon.log and noticed the following:

Any chance this could be related to my issue?

Hello Matt,

Setting the EUI in the global_conf file is not mandatory, as the local_conf file overwrites the parameters in the global_conf one. But it is not a problem nor it will affect gateway in any way.

It seems that the problem is caused by the concentrator that is not starting:

Can you check if the SPI is enabled via the command: sudo raspi-config.
Head to the Interfacing Options → SPI

Enable it if it is disabled and reboot the Pi.

Hi Martin,

Gotcha, and confirmed SPI was enabled and rebooted, but am still receiving the same error log regarding the concentrator seen above

Hello @mjr445,

I’m getting out of ideas what could be wrong. When you power the RPi, does the power led on the HAT is on? What power adapter are you using?

Most of the time, this issue is caused by a wrong reset pin. But the RAK2245 firmware should configure that pin.

Have you tried again with a fresh install of the firmware?