RAK2246 with RPi OS

Is there a way to run the RAK2246 hat on a Raspberry Pi Zero W with the current RPi Foundation operating system? I am finding the ChirpStackOS to be seriously limiting. There does not appear to be any way to add application programs to the OS.

Hei @Keith ,

Our own firmware on it actually. You can also simply use the repot here:

There are instructions how to install, etc.


This installation process does not work on the Raspberry Pi Zero W. Among other errors, it gives this message: “WARNING: ChirpStack is not support for this rpi model.”

What can I do to get the RAK2246 to work on the Raspberry Pi Zero W with Raspbian Buster LITE?

You’d need to compile Chirpstack for ARM v6 - at present it’s compiled for v7 / armhf which works with Pi 3 and above.

There doesn’t seem much incentive to do this on the Chirpstack forum.

Thank you, Nick. I am disappointed that RAK Wireless would sell the RAK2246 without warning customers that there is no way to run application programs on it.

Hi. I installed chirpstack some time ago in a RPI Zero W (when it was called lorawan server). I see precompiled versions (.deb packages) for RPI Zero W ARM V6 (and other versions precompiled in .deb) in the following links:




It doesn’t make Smoothies or do your tax return either, both things I have computers doing for me, neither of which have any facilities for acting as a LoRaWAN gateway but I’ve got over the disappointment of that fact not being documented by the manufacturers.

No where in the documentation does it say it runs Chirpstack. I guess the principle reason RAK’s docs don’t say you can’t run applications on it is because you can, within the constraints of that additional load impacting on its ability to perform the necessary gateway requests on time, but that’s your choice. I do in fact run a couple of extra background tasks, mostly backing up for when the card goes south on me, but nothing very heavy duty like a whole LoRaWAN stack.

The reason I don’t is because the Pi Zero is a single core with 512Mb of memory and a SD Card for permanent storage. Upon this, as well as the packet forwarder, you need Mosquitto, PostgreSQL, Redis plus the ChirpStack itself. You’d also need a pretty bullet proof SD Card as well.

And then there is the price. You buy a low cost gateway that’s sold as a gateway and you are surprised that it can’t also act as a server as well.

I’ve two of these gateways, they are great for using with client training, internal development and trying things out that I really shouldn’t do with an industrial gateway lest I let the magic smoke out.

I have a RAK833 on a Pi 3 that’s got a USB to mSATA SSD as a gateway that has just enough X on it to run Chrome so it can also do double duty as a dashboard. That works just fine with the occasional stutter on the display if there’s a lot for it to update. But my Chirpstack & TTN v3 stack are running on proper servers as the bother of setting them up precludes doing it all over again when the Pi’s mass storage fails.

As you can tell, I don’t share your feelings.

Classy. You wouldn’t per chance be a refugee from the Stack Exchange? Or maybe a frustrated comedian? Anyway, next time you decide to write so much prose, try to make it useful.

Thanks, Alberto. I tried this yesterday, and it doesn’t seem to work on the latest Zero W. I’ll keep working on it.

I can touch type, so that’s not “much” for me.

The funny thing is, amongst my other talents includes running Chirpstack Gateway OS on the RAK7246 - a Pi Zero W with RAK2256 - and run applications on it. So I must be a comedian.

If we’ve got past you having a pop at RAK, what actual application are you hoping to run?

No need to be dissappointed, because there actually is no such limitation.

What specific problem did you run into in trying to do so?

Identify problems and solve them specifically.

What application are you trying to install anyway?

And in terms of chosing OS image, do you need chirpstack? What sort of LoRaWan network do you want to use this on?

Expressions of frustration may be general, but actual solutions depend on specifics.

From the ChirpStack forum, it started as an issue with installing packages on to Gateway OS to run some Python, then tried the RAK firmware that isn’t configured for the ChirpStack setup for install due to the different ARM version on the Pi Zero and we appear to have stalled at using a copy of Raspberry Pi OS Lite and installing the ARM v6 builds.

With the help of brocaar in the ChirpStack forum, I was able to find the solution. Here are the general steps:

  1. Create the latest Raspberry Pi OS LITE image, and set up connectivity
  2. Follow GitHub - RAKWireless/rak_common_for_gateway, stopping after the git clone
  3. edit ./rak_common_for_gateway/chirpstack/install.sh to remove (or comment out) the 5 lines that start with: rpi_model=do_get_rpi_model. This will make the script install the wrong ChirpStack binaries, but will perform all the configurations, postgresql, and mosquitto setups properly.
  4. run the command “sudo dpkg --add-architecture armel”. This allows the installer to install the …armv6.deb version of ChirpStack
  5. use wget to retrieve the armv6.deb files of the ChirpStack version of your choice from https://artifacts.chirpstack.io/downloads
  6. copy the ChirpStack .toml configuration files to a safe place
  7. install the ChirpStack binaries with "sudo dpkg -i "
  8. reboot
  9. use “ps -aux” to see if everything loaded OK
  10. depending on the ChirpStack version you loaded, the .toml configuration files might be OK. If not, copy them back and reboot.

I know this process is crazy, but it is well worth it. By my tests, the RPi installation leaves more free disk space and more free memory than the ChirpStackOS install, and you will have all the RPi tools available.


Sorry, Step 3 should end with:

Continue with the RAK install, choosing the RAK2246.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.