RAK2247 RaspberryPi3 Gateway Can't Connect to TTN

Hello !
I am new to Lora but trying to set up my first gateway and connect it to The Thing Network V3 (TTN).
I am using a RAK2247 (SPI) on a Raspberry Pi 3.
I followed the RAK tutorial : GitHub - RAKWireless/rak_common_for_gateway.
Got the latest version of the OS lite, install the firmware, and configure the gateway using
“sudo gateway-config”
I first modified the global_conf.json file generated by the firmware by “hand” with the information i got from the TTN overview page with the adress “eu1.cloud.thethings.network” and the EUI built with the MAC adress and FFFE in the middle.
It did not work so I used the global_conf.json generated by TTN with the same result.

My Gateway is connected to internet i can ping google.

I did not succeed to see my gateway connected on TTN, and i read all the topics i found on this kind of issue.

Modification by “hand” of firmware global_conf ///////////////////////////////////////Generated global_conf file by TTN
///////////////////////////////////////////////////////////////////////////////////TTN Overview////////////////////////////////////////////////////////////////

If you have some ideas it would be great !

What does the gateway write in the local log you can watch with sudo journalctl ? Is the packet forwarder even running? Was it (or the entire pi) restarted after making the configuration changes?

Are there any in range nodes sending packets for the gateway to receive and forward to TTN? If not, merely being connected in the sense of stats traffic may not show up, without there being any radio traffic.

1 Like

Hello @Poubelles,

@cstratton is absolutely right. You can check the logs to see if there is any activity.
Can you also check if the I2C, SPI and Serial Port Hardware are enabled on the RPi?

sudo raspi-config


Hello, thanks for your answer !

@cstratton After checking the local log I saw an error that i fixed following this topic about concentrator and default port : RAK2247-SPI (Pi-Supply) - failed to start concentrator :-(

There isn’t any node at the moment, is there a way to artificialy simulate one or just a command that allow the gateway to send something to TTN just to check the connection ?
But I thought there was update status message sent automaticly ?

@Martin Yes I did it as it was indicated in the GitHub tutorial

Here is the local log now :


Hello @Poubelles,

What power adapter are you using for the RPi? It is recommended to use 5 V at least 2.5 A Micro USB Power Supply (or even 3 A). Change the adapter and try to connect again.

Hello @Martin I’m using a USB to micro USB connected on a PC. I don’t have the low power warning every time but sometime it’s here I don’t know why…


It might be enough to power the RPi via a USB to micro USB cable but it is not enough for the RPi + RAK2247. You’ll need to grab an adapter to make the gateway work.

Thanks @Martin
I struggled but finaly found a 5V 2.5A Raspberry adapter but i’m not sure it changed something…

Looks like it’s running now, but you may not see much without actual node signals to report in.

And no, you’re not supposed to fake nodes.

1 Like

You don’t really need a node to check if gw is working ! You should see the heartbeat sent every 30s by gateway to TTN/TTS :wink: and it should also show up as online there !
Side note: for configuring RAK gateway to connect at TTS, you just need to change URL in packet forwarder and restart it, nothing else is needed :wink: and same for Helium using Helium URL (and each time for sure declare the gw in console :wink: