Rak2270 with STMCubeProgrammer

RAK2270 Sticker Tracker with the cube programmer

@carlrowan Getting there just have to figure out the connections.

Hi @jerteach ,

Common issues that I know of

  1. Loose jumper wires
  2. Boot0 pin not pulled-up
  3. COM port selection mismatch
  4. USB-Serial not supported (RAKDAP1 as USB-UART doesn’t work in my PC)

I did a quick test on RAK3172-SiP. It is detected fine.

Thanks @carlrowan interesting baudrate for you (230400) mine trys 115200.

Good ideas about renaming the main .hex file without periods and spaces, I will try that.

Reminder I am using the RAK2270 I assume everything is the same as the RAK3172-SiP.

One weird little thing, how do you pull BOOT0 high on the RAK2270 sticker Tracker Development board and stably keep it high for the .hex file upload?

I did some test but nothing really different. I can’t seem to see a setting to use the SWD connections with the stm32cubeProgrammer but that might be an option since on the other thread I am having some success.

Hi @jerteach ,

Making the baudrate slower is an option as well.

RAK2270 is based on RAK3172-SiP so the process is the same.

With regards to BOOT0, it is beside the VCC so it is not really difficult. Maybe solder a wire where you can short by twisting it.

The SWD connection to STM32CubeProgrammer will require you an ST-Link. I doubt that it can support the RAKDAP1.

Thanks @carlrowan not sure why but the st-link-v2 worked write away. Possibly even worked without the BOOT0 set HIGH. I will have to test that out. Anyway, I guess I can un-brick a RAK2270 now. I will test things out tomorrow and hopefully make a video. Thanks so much for your help.

Here is an image of my debuggers. I try not to use them.

RAKDAP1 → Particle-DAP-debugger → ST-Link-V2 -->J-link-Edu


That’s correct. STlink will work right off-the-bat. It depends on your setting if you need control on reset but swd pins is enough.

Boot pin is only needed for the UART bootloader.

@carlrowan I would still like to get the RakDap1 working for both drag and drop and pyocd but for now the ST-Link-V2 is working well.

Here is the video link here

It is easy to upload the firmware.hex file but also easy to upload an Arduino compiled binary (Arduino IDE → Sketch–>Export-Compiled-Binary). I saw the ArduinoIDE “sketch–>upload using programmer” but could not get it working.