RAK3172 and RAK7289V2 Gateway Communication Error Questions

Hello.

Before preparing for the first mass production with RAK3172, transmission tests are being conducted with a large number of devices.

When data was transmitted to 10 devices at the same time, the following error occurred, and packet analysis at the gateway confirmed that it did not come in at all.

It wasn’t a problem when it was developed with one device,

When I sent it from multiple devices at the same time, the message “+EVT:SEND_CONFERNED_FAILED(4)” was output and the packet was not checked by the gateway.

Please let me know how to resolve these errors.

If the error "+EVT:SEND_CONFERNED_FAILED (4)"is output, the data will take up to 180 seconds to arrive because the data transfer will be successful after a continuous retransmission.
So we need to solve this problem in order to send it as soon as possible.

[Device & Gateway & ETC description]

  1. gateway model : RAK7289 V2
  2. device model : RAK3172
  3. RAK3172 Setting value:
  • MODE : OTAA
  • ADR : OFF
  • DR : 0
  1. region: KR920
  2. Network sever : Chirpstack V4

[Error Sample]

1.Log of RAK3172 that sent data at “09:48:06” but failed to send data

  1. Packet capture screen monitored by gateway but not received data after “09:48:01”

Just in case, I delivered the same content through the email below.
e-mail: [email protected]

Hello @song

I will close the ticket, because it will be the same person answering you in our Helpdesk and here :wink:

Did you enable all possible 8 channels in the LoRaWAN server for KR920?
Did you enable LBT on the devices?
How many retries did you setup for confirmed packet sending with AT+RETY (or the API function)?
What is the send interval of each of the devices?

Our gateway has 8 channels it can listen to. If 10 devices are sending at exact the same time, some of them will use the same frequency when sending the packet, so there is either a collision (can be reduced with LBT) or one succeeds and another one fails.

If you have set only one retry, the failure rate will increase.

KR920 allows 13 bands/frequencies to be used. You could try to use a 16 channel gateway and allow all 13 bands/frequencies to be used. How to setup this configuration is more a question towards my colleague @velev

Other than that, there is never a guarantee that a packet transmission is successful with LoRaWAN.

Hi @song,

I think this is related to the other forum topic you posted.

You shared this log there which I think causes the failure of downlinks.

If 10 devices are near each other and sending packets simultaneously in DR0 setting, there could be a chance of collision because DR0 will take more air time. Maybe as experiment, make the DR higher or have larger gap between uplinks. This is something you can also try to avoid collisions.

Imagine if you have 10 devices that has failure of downlink and will keep repeating on DR0 setting, there is a big chance to choke the frequencies being used.

When I read your answers and think about it
It seems as if one device per frequency channel is occupied, and the other device cannot be used.
Am I right to understand?

And if the retransmission interval fails, it is done once every 5 seconds and transmitted up to 20 times.

Thank you for your answer.

Once the DR is raised, it works well, but it can’t be changed because it seems to be an environment where DR is set to zero and has to be used regularly.

Then, I will read the answer and ask you another question.

  1. I understood that if the uplink interval is 5 seconds now and it’s a problem, we need to increase it more. Is that right?
  2. If one device is transmitting data per channel of frequency, will the data of the other device be ignored?
  3. It looks like a device communication problem, and is there any way to solve it with the settings on Gateway or ChirpStackV4?
  4. If 8 channels are available and 9 devices transmit data at the same time, does the other 1 device find the frequency on its own until the unused frequency comes out?

Hi @song ,

  1. Yes. You have to increase the interval. If you need that frequent uplink interval on a single device, LoRaWAN is not the optimal choice.
  2. Best case, one can still be received. But also possible both will result to error.
  3. I do not see yet there is communication problem Seems over utilization of the frequency used.
  4. Use of frequency is random but it hops. More channels like what @beegee suggest will allow you to cover more devices.

Thank you.

Thanks to you, my questions have been solved.

I’m glad it’s a simple matter…

Then, I have a question because I have a question about the 4th answer.

Does LoRaWAN device automatically hopping all frequencies used in KR920 when hopping?

Yes. It will hop automatically.

image

This is 8ch frequency configuration used on my region (as923-3). As you see, it is distributed to all frequencies.

1 Like