RAK4270 Breakout Board Sleep Issue

Hello,
i am using RAK4270 on the RAK Breakout Board with the latest firmware and try to figure out how to set the sleep mode to save battery.

The device works great, uplink, downlink everything is perfect.
When i send the
“at+set_config=device:sleep:1” command
I always get ERROR:80 (device busy)
What are the requirements for the sleep mode?

Here is the output of the RAK Serial Port Tool:

at+version
OK RAK4270 v3.3.0.18

at+set_config=device:sleep:1
ERROR: 80

Maybe i have wrong understanding from the sleep command.

Many thanks in advance for your help!

I am also experiencing this exact issue.

My output is as follows.

at+version
OK RAK4270 v3.3.0.17

Hi @sebastian @WillAnderson ,

The R&D team is now looking about the issue. I’ll let you know ASAP for updates. This issue do not exist before so there might be a bug on the recent FW release.

Thank you @carlrowan .

I seem to have solved my issue. By changing my device from Class C to Class A, It can now enter sleep mode. I guess a note in the AT Command Manual about this would be helpful.

1 Like

That is a good catch @WillAnderson .

I am checking now on what FW version the default class was changed from Class A to Class C. I will update the docs to put an extra small note about this. Thank you.

AFAIK the default is Class A. I had been using my device in Class C, but have changed back to Class A.

Thanks a lot!
That solved it for me.
And deep sleep makes no sense with class C.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.