RAK4270 FW Timeout

When it try to upgrade the firmware on my RAK4270 module via UART 1 using RAK DAPLink and RAK Device Upgrade Tool I get the error “Device firmware upgrade timeout”.

The present version of firmware running on the RAK4270 is V3.3.0.18.

I’m trying to load a custom FW bin file generated using RUI V2 examples and complied using the RAK Online RUI compiling tool.

With regards to the DAPLink connections to the RAK4270, I’m using DAPLink pins U_Tx & U_Rx connected to pins 4 & 5 RAK4270 with DAPLink also providing 3.3V & GND connections to pins 20 & 19 on the RAK4270 as per the getting started guide.

Any help would be very much appreciated.


I hooked the output from the DAPLink to another RS232/TTL converter observed the output when running the FW update tool. The following two commands were observed “at+boot” and “at+update”. when run this two commands on the RAK4270 uart interface I observed the following responses:

LoRa (R) is a registered trademark or service mark of Semtech Corporation or its affiliates. LoRaWAN (R) is a licensed mark.

RAK4270 version:
UART1 work mode: RUI_UART_NORMAL, 115200, N81
UART2 work mode: RUI_UART_NORMAL, 115200, N81
Current work_mode:LoRaWAN, join_mode:OTAA, MulticastEnable: false, Class: C
Initialization OK


Looks like the RAK4270 doesn’t recognise the “at+update” command?

I repeated the same process of compiling RUI V2 firmware using online tool for RAK811 module and updated firmware using DFU tool and this worked fine.

Any suggestions?

I apologies for all the edits above regarding my issue. However, I have found a solution to my issue.

Using the RAK DAP1 Flash and Debug tool I connected to the SWD interface on the RAK4270 and flashed “RAK4270_v3.3.0.17_Boot+App_20210525.hex” using pyOCD using the following command.

pyocd flash -t stm32l071kbux RAK4270_v3.3.0.17_Boot+App_20210525.hex

After doing this the RAK4270 no longer responded to at commands so I tried to flash the “RAK4270_v3.3.0.17_App_20210525.bin” firmware using the DFU tool and this worked!

From here I was able to update to firmware V3.3.0.18 and go one to load my custom RUI firmware.

The RAK4270 now responds to the “at+set_config=device:boot” and goes into boot mode when executed.

I’m still not sure why the original v3.3.018 firmware supplied on the RAK4270 didn’t work with the DFU tool.