RAK4600 Breakout Board UART problem


Hello everyone,
I have a problem connecting to UART via UART adapter. Device firmware is: V3.4.0.14

When I do it according to the documentation:

As I connected to UART1, the effect is the same. I was only able to connect via BLE.

I tried on two different adapters, each of them works on different devices.
I am using your RAK Serial Port Tool software.

I also noticed that until I send any at command via BLE, the current consumption of the board is very small.
Only after sending same command does it increase significantly.

I use an external power supply for power supply.


Device firmware: V3.4.0.14
External power supply: 3.3V, 1A
Software: RAK Serial Port Tool
UART adapter: USB-UART FT232



Could someone explain to me how to connect the board so that it works over UART?

Welcome to the forum @energia_11

Can you try to connect to the other UART of the Breakout Board like this:

As I wrote above, I also tried to connect in this way, but the connection to UART1 also does not work.

Maybe some other way to solve the problem?

Do you have another UART-USB adapter that you can try?

Can you try another terminal application than our RAK Serial Port Tool? I am having problems with the tool on Win 10.

I tried on two different adapters.
I have windows10 but I also use Linux and it doesn’t work there either

Then I am out of ideas.

If the module is within the warranty period, you can ask for replacement through our customer support channel [email protected].