RAK4600 does not communicate

Issue: I can’t communicate with RAK4600.

I want to use the RUI API but I cannot send the .bin file to the RAK4600 with the Device Firmware Upgrade Tool RAK Serial Port Tool program. I have tried using the AT commands to check the serial port and I do not receive a response from the RAK4600. I have been programming the RAK4600 so far with the Segger Embedded Studio program, and I have had no problem but I would like to be able to use the RUI API.

I have updated the firmware through the SWD connection with the RAKDAP1 and the command pyocd flash -t nrf52 RAK4600_v3.4.0.14_20200925.hex successfully.

I have also tried with the Arduino environment but I am not able to establish any type of connection either.

I have followed all the RAK tutorials and I am not getting the results.

I would like to know what I am doing wrong or how to solve the problem.

Hi @pablorubioj , welcome to RAK forum :slight_smile:

To update RAK4600, you can use Jlink/RAKDAP1 via SWD pins or you can do it via Bluetooth using nRF Connect app. You cannot use RAK DFU Tool for RAK4600.

It seems you already uploaded the latest firmware using RAKDAP and pyocd. Can you confirm the connection of your UART lines (RX to TX and vice-versa)?