RAK4600 Evaluation Board Firmware Error

I’ve been trying out the RAK4600 Evaluation Board with the RUI Online compiler, and would be grateful for a bit of help.

I’ve compiled a couple of firmware files using the RUI compiler, the 4600 and Beacon Scanner examples.

They compile ok and I flashed the compiled hex files over J-Link to the 4600 with no issues.

When I power the eval board through the USB they both work fine, can view output over RTT and send AT CMDs over Serial, set Lora keys, view scanned beacons, etc,.

However, both firmware files show an error on loading when the board is powered via the Battery pins.

The error from the RTT Viewer is:

00> [00:00:00.000,000] app: RUI Version: v3.0.0.9
00> [00:00:00.000,000] app: Setting vector table to bootloader: 0x00078000
00> [00:00:00.000,000] app: Setting vector table to main app: 0x00026000
00> [00:00:00.004,000] app: ERROR 133 [NRF_ERROR_MODULE_ALREADY_INITIALIZED] at …/…/RUI/Source/nordic/driver/general_uart.c:326
00> PC at: 0x00043987
00> [00:00:00.009,000] app: End of error report

I’ve noticed the latest downloadable firmware is v3.0.0.8 and the RUI compiled firmware is v3.0.0.9.

I don’t encounter the same error with v3.0.0.8 firmware and the board powered form the battery connector.

Is the v3.0.0.9 RUI compiled firmware doing something different on loading the softdevice and nrf modules?


Dear Paul,
From the above, you have burned successfully, why the following version of the log again.
By the way,The latest compiled firmware is V3.0.0.9, however, the released firmware is only released.

Thanks Nicholas,

My query was really about the behaviour, for me, of the RUI compiled v3.0.0.9 firmware once flashed to the board.

After flashing it loads and works as expected if the RAK4600 Eval board is powered via the USB.

I get the loading RTT error when powering the RAK4600 EVAL board via the battery or Vin pin with the compiled v3.0.0.9 firmware.

So with USB power the compiled firmware starts fine, with Vin or battery power it leads to loading error ERROR 133 [NRF_ERROR_MODULE_ALREADY_INITIALIZED] at …/…/RUI/Source/nordic/driver/general_uart.c:326

Does this make sense? Perhaps something to do with the RAK5005 WisBase? or is the compiled V3.0.0.9 firmware (no changes made to RAK examples) doing something different then the v3.0.0.8 release?

v3.0.0.8 firmware works for me no matter how the 4600 Eval board is powered.

I’m trying to test the compiled firmware for low power consumption which is why I don’t want to power Via USB.

With v3.0.0.8 firmware in sleep mode I can get to 20uA, sending the command via serial.


Dear Paul,
Please send e-mail to me,I will give you solved solution.
E-mail:[email protected]


Thanks for your previous help.

I have a further issue that I’m seeing on both the RUI online compiled firmware of the 4600 example and the beta firmware you gave to me.

On both I can use AT commands to to configure the LoRa settings - ABP or OTAA keys, region, etc, fine.

If I send the AT command for the device to sleep(at+set_config=device:sleep:1), or set a send interval with mode RUI_AUTO_ENABLE_SLEEP, the RAK4600 will sleep no problem, drawing only 3 - 10uA depending on the firmware version.

However, once I send a LoRa TX, the power consumption stays around 4.4mA after it’s sent. Following the LoRa Tx the RAK4600 responds to AT sleep commands over UART with an ‘OK’, or if a sleep interval is called in the RUI customised firmware(rui_lora_set_send_interval(RUI_AUTO_ENABLE_SLEEP,app_lora_status.lorasend_interval), the module prints that it is going to sleep, but the power consumption remains high.

So my question is, why can I obtain low power consumption via the RUI API’s or via the UART AT device sleep command before sending a LoRa Tx, but once I send it the power consumption remains high after it has completed and has supposedly returned to sleeping?

It can’t be due to the UART, as the module sleeps with low power consumption from an AT command via UART before a LoRa Tx is sent.

Am I doing something incorrectly? It is possible to put the RAK4600 into a low power sleep(3-20uA) between LoRa Tx uplinks?

I’m using the 4600 breakout rather than the evaluation board I tried previously.


Dear Paul,

I have send you e-mail! Please check it!