RAK4600(H) not responding to AT commands

I have the following scenarion :

RAK4600(H) with evaluation board connected with micro usb to windows 10.

Using the RAK_SERIAL_PORT_TOOL_V1.2.1. the 4600 is not responding to AT commands.

Tried to flash the firmware with RAK LoRaButton Upgrade Tool V1.0 without success.

Tried with Micropython-on-RAK5010 serial tool without success

I cant see the device also in the NORDIC app.

I’ve tried to put the device in boot mode connecting RX1 to GND but same result.

Can you please advice ?



Hi Daniel,

Welcome to RAK forum :slight_smile:

Is the image you shared from your device? Were you able to get the firmware version of your device? Is the device COM port detected on the device manager? Have you tried a different USB cable? Can you try power it on then scan with nRF Connect mobile app?

Hi Carl ,

Yes the screenshot is from my pc. No I was not able to get result from any AT command.

Yes the COM port its properly detect.

Yes I’ve tried also with different cables.

I’ve tried that too "Power it on then scan with nRF Connect mobile app "

As I look at the screenshot, you are checking the version but the replies are mixed of messy ascii and hex values.

Have you loaded a different FW on it?

Hi Carl,

I’m not able to load the newest FW because i cant see the device from the nRF Connect mobile app.

The mixed of messy ascii and hex values are not replies from the AT CMD - just logs from the current FW.

Can you please advice how can I load FW ?

That’s strange. Your unit seems not have the RAK default firmware.

Since nRF Connect cant detect it, then you can only update the firmware by programming the nRF chip. One why is by using RAKDAP1 - RAKwireless Documentation Center

You can also use Jlink if you have.