RAK4630 5005 USB connection cannot be detected when plug in PC

Hello there,

I’m currently using RAK 4630 5005 Wislock. When I want to connect them to PC through USB, it always showed USB malfunctions unknown devices.

I have tried 3 USB cables, 2 PC, and 3 boards. All showed USB malfunctions.

And when I write s140 hex files into boards, it will show JLINK cannot power on CPU (error -1). I don’t know if it leads to the problem.

The board can operate properly on making ble connections and sending data. But just cannot use USB connections. Thank you.

Hello @zzxxcv, welcome to the forum.
this could be a Windows Driver system (You didn’t mention which OS and which OS version you are using, I am just guessing).

Maybe you can try to run [this driver installation app adafruit_drivers_2.5.0.0.exe and see if it helps.

Hello @beegee !

Thank you for your reply. I use windows. I have just tried the .exe file you sent and restarted. But it still shows unknown USB Devices.

Which Windows version are you using?

Can you try the following:

  • connect the WisBlock to your computer over USB
  • double press the reset button on the WisBlock fast
  • check if Windows recognizes WisBlock as an external USB drive

I’m using Win 10 Home 20H2 with Os build 19042.1052

I have tried all the actions you suggested. I tried to press reset twice when I saw your reply to previous post. When I pressed twice, the unknown USB drive page will disappear. Then when I reconnect USB, it still shows unknown USB.

Windows cannot identify it as a normal USB, just an unknown.

That is strange, I am running Windows 10 as well and it installed the drivers automatically.
It uses the build in usbser.sys driver:

I didn’t experience your problem and I have 6 WisBlock Core RAK4631 here. As you have the problem with 3 different WisBlock Base boards, I don’t think it is a HW problem on the Base boards.
Can you send me an image of the WisBlock Base board like this:

Hello @zzxxcv ,
To check your USB drivers please install zadig:
On zadig menu click on Options-> List All Devices.
This is the correct driver for RAK4630

1 Like

Hi there,

I am new here, and I am having similar issues. My RAK4630 was working for a little bit, and now the USB connection is not recognized by the PC. It gets detected when i press the reset button twice and it connects as a drive to the PC (FTHR840BOOT). I tested three different cables, and tried on two PCs and one Linux machine. Anyone seen similar issues?

Thanks. N

Do you have any other modules plugged to the RAK5005-O base board?

It could be you need to update the bootloader => Updated bootloader for RAK4631 - #3 by jpmeijers

I had the 1906 enviro sensor, and it is the same after removing it. I will try to update the boot loader. Looks like i have a version from June 2020:

UF2 Bootloader 0.3.2-109-gd6b28e6-dirty lib/nrfx (v2.0.0) lib/tinyusb (0.6.0-272-g4e6aa0d8) lib/uf2 (heads/master)
Model: Adafruit Feather nRF52840 Express
Board-ID: nRF52840-Feather-revD
SoftDevice: S140 version 6.1.1
Date: Jun 16 2020

The upgrade with BLE OTA DFU worked. Thanks!

Good. The bootloader was an old one and had a problem with the USB.
When did you buy the board. All RAK4631 should have the new bootloader already since June this year.

1 Like

They are still coming out with the original bootloader @beegee, or at least they were four weeks ago

Thank you for the information. I think I have to step on some toes then.

Sorry for that. They should all be updated already.

I bought the Helium dev kit few weeks ago. It will be good if they can ship them with the updated bootloader. Thanks.