RAK4630 Working example?

I’ve serious problem with WISKIT 2.
I’m unable to work with it in conjunction with a D4D GW.
I’ve compiled the sketch for testing the GPS + Accelerometer, but i need for debug purpose a more simply application for understand where is the problem https://forum.rakwireless.com/t/d4h-rak7248-wisblock-kit-2-and-chirpstack-server-no-device-data/4096/2
On the github repository i’ve found an example that send an Hello!
This example doesn’t compile:

too many initializers for ‘lmh_callback_t’ {aka ‘lmh_callback_s’}

I understand that it’s difficult to mantain a big repository like this, but where i can find a simple PING test for verifiy where is the problem on my implementation?

Also on the gateway the image shipped with the gateway D4D, the apt-get update doesn’t work.

Hi @ciclonite ,

The problem could be the lower version of SX126x-Arduino library.

Check you check if you have v2.0.0 installed?

Btw @ciclonite , it’s good if you can post separate topics on different challenges you have :slight_smile:

@velev and @Hobo can help you on the gateway update issue.

The apt-get update worked for the ChirpStack repro but not for the Pi ones, all of which resolved properly, so we know DNS is working.

A whole variety of things could have been going on at that single point in time that caused the update to fail. Question is, does it do it again?

Hi @carlrowan thanks for your reply. With the version 2.0.0 compile without problem! Thanks!

@carlrowan Sorry for my mistake, but having already opened two posts and seems excessive for me to open another! :slight_smile:

@nmcc : yes do it again. The strange thing is that i have a stock firmware; i have only configured the gateway using gateway-config command.

I’m not sure if you’ve tried again and got the same error or if you will be trying again.

It does seem like a simplistic solution, but if you used the stock firmware, then apt-get update not working isn’t really a RAK thing, more a Raspberry Pi thing and, as I suggested, with networks & repro’s, anything could have been happening at the point in time you tried to retrieve the update list.

Thanks for reply, i’ve tried many times, the last one 5 min ago. I dont think it’s a rpi thing, because i’ve bought two D4D gateway, and both do the problem! ( tested on two different network). I think that the problem may be a config shipped with the stock fw.

Ah, you mean the RAK firmware, not the vanilla RPi firmware, my apologies.

I haven’t seen this issue, there was one with DNS last autumn but I haven’t setup a gateway with the latest RAK download of late apart from the RAK7246 which is a different build. As I’ve got other gateways to deploy shortly (once we can get to them, Covid!) I can give it a try here.