RAK4631 BLE OTA problem

i had like to know that is there any minimum current range for rak4631_ble_ota_dfu and is there any IO or any Pin to be in Grounded or something like that because i am using my own customized board using the RAK4630 which is using most of the IO, I2C and UART.

i tried ble ota in RAK4630( not in our customized Board). it works fine.

i need to get some clues. Does anyone knows about it .

On our WisBlock modules, the RAK4630 is supplied with a 3.3V main supply + VBat for the internal DC/DC of the nRF52.

Our WisBlocks Base Boards can supply with a minimum of 300mA and a maximum of 600mA, depending on the source.

No GPIO is used for BLE OTA DFU. It is all controlled by the Bootloader and Softdevice. The application just have to offer the BLE OTA DFU service and the rest is done automatically.

i got some clue. i told you that i tried the ble ota in rak4630 module(not in customized board) i tried upgrade it to RUI3 by this link and then convert back into Rak4631 arduino bsp by this link. and then i upgraded the bootloader by this link. i uploaded the rak4631 ble_ota_dfu sketch and the issue arises this this RAK4631 also. am i missing something or using the old files?

I am switching devices between RUI3 and Arduino all the time and I never saw an issue with BLE.

If you flashed all three files rak4631_factory_application.zip, rak4631_factory_bootloader.zip and rak4631_factory_softdevice.zip it should work.

To be save and if you have a JLINK or a DAPLink (like our RAKDAP1), you can do a chip erase, then flash the firmware, bootloader and softdevice again, but you will need the HEX files to do so.

At first i have a newley arrived RAK4631 module with RUI3.

I converted it to Arduino BSP in Windows by this procedure.

BLE OTA update works fine.

And then i updrade it to RUI3 by this procedure and convert it back to Arduino BSP.

After this i can’t able to use BLE OTA update. the RAK4631 got restart continueously.

could you share me your files for converting between RUI3 and Arduino.

I am using the files you can find in the tutorials or I am using JLink to do a chip erase and then flash the files.

Do you have access to a JLink or a DAPLink?

I can give you the HEX file, but without a Jlink or a DAPlink they are useless for you.

i didn’t have JLink or DAPLink now. once i have it on my own i will ask you the files.

I have RAKDAP1 with me could you help me what to do next.

First a warning.
If something goes wrong, you will brick the RAK4631.
If it fails to flash the first time :arrow_right: retry :arrow_right: retry :arrow_right: retry

(1) Follow the RAKDAP1 Quickstart to install everything you need.

(2) Prepare the connections.
Make sure the RAK4631 is powered by USB or battery!!!
The 3.3V output of the RAKDAP1 alone is not sufficient to power the RAK4631 correctly!

(2) Get the required package

pyocd pack --i nrf52840

(3) Perform the chip erase

pyocd erase -t nrf52840  --chip

(4) Flash the firmware

pyocd flash -t nrf52840 RAK4631_latest_final.hex

RAK4631_latest_final.hex (2.4 MB)

It works.

Thank You for your Quick response and Guidance.

It helped me a lot to complete my work.


BLE is now working after you flashed the complete HEX file?

Yeah and the OTA update is also working Good.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.