RAK4631 keeps restarting

I have RAK4631 meshtastic starter kit that was working fine until today. I tried hooking it up with the Harbor Breeze Solar light hack. Now it seems to be in a constant boot loop. Whenever I try to change a setting whether it is via the Android BT app or from a serial connection via the windows desktop client the module just reboots and won’t.let any changes go into effect. I tried reinstalling meshtastic but that didn’t help. Also tried a factory reset via the Windows CLI and got an error saying it wasn’t permitted. Worried I may have fried the radio by possibly my ipex to sma pigtail was defective or possibly got it too close to a Lilygo module??? Help!

What is a “Breeze Solar light hack”???

The max input voltage on the solar panel connector is 5.5V

If the input was much larger you have damaged the board.

Well it is just an 18650 as part of a solar landscaping light. RAK WisBlock Harbor Breeze Solar Light Enclosure Hack | Meshtastic just for reference.
This is what I get out of the serial monitor from Arduino

DEBUG | ??:??:?? 8 [GPS] Probing for GPS at 38400

WARN | ??:??:?? 9 [GPS] Failed to find UBlox & MTK GNSS Module using baudrate 38400

INFO | ??:??:?? 11 [EnvironmentTelemetryModule] Environment Telemetry: Initializing

INFO | ??:??:?? 11 [EnvironmentTelemetryModule] Init sensor: SHTC3

INFO | ??:??:?? 11 [EnvironmentTelemetryModule] Opened SHTC3 sensor on i2c bus

DEBUG | ??:??:?? 11 [GPS] Probing for GPS at 57600

WARN | ??:??:?? 12 [GPS] Failed to find UBlox & MTK GNSS Module using baudrate 57600

INFO | ??:??:?? 12 [EnvironmentTelemetryModule] (Sending): barometric_pressure=0.000000, current=0.000000, gas_resistance=0.000000, relative_humidity=41.869999, temperature=24.820000, voltage=0.000000

DEBUG | ??:??:?? 12 [EnvironmentTelemetryModule] Initial packet id 1605844693, numPacketId 4294967295

INFO | ??:??:?? 12 [EnvironmentTelemetryModule] Sending packet to mesh

DEBUG | ??:??:?? 12 [EnvironmentTelemetryModule] Update DB node 0x9fd58bcf, rx_time=0

DEBUG | ??:??:?? 12 [EnvironmentTelemetryModule] handleReceived(LOCAL) (id=0x5fb73ed7 fr=0xcf to=0xff, WantAck=0, HopLim=3 Ch=0x0 Portnum=67 priority=1)

DEBUG | ??:??:?? 12 [EnvironmentTelemetryModule] No modules interested in portnum=67, src=LOCAL

DEBUG | ??:??:?? 12 [EnvironmentTelemetryModule] localSend to channel 0

DEBUG | ??:??:?? 12 [EnvironmentTelemetryModule] Add packet record (id=0x5fb73ed7 fr=0xcf to=0xff, WantAck=0, HopLim=3 Ch=0x0 Portnum=67 priority=1)

DEBUG | ??:??:?? 12 [EnvironmentTelemetryModule] Expanding short PSK #1

DEBUG | ??:??:?? 12 [EnvironmentTelemetryModule] Using AES128 key!

DEBUG | ??:??:?? 12 [EnvironmentTelemetryModule] nRF52 encrypt fr=9fd58bcf, num=5fb73ed7, numBytes=21!

INFO | ??:??:?? 12 [EnvironmentTelemetryModule] Should encrypt MQTT?: 1

DEBUG | ??:??:?? 12 [EnvironmentTelemetryModule] MQTT onSend - Publishing portnum 21 message

DEBUG | ??:??:?? 12 [EnvironmentTelemetryModule] MQTT Publish msh/US/2/c/LongFast/!9fd58bcf, 67 bytes

DEBUG | ??:??:?? 12 [EnvironmentTelemetryModule] Sending mqtt message on topic ‘msh/US/2/c/LongFast/!9fd58bcf’ to client for proxying to server

INFO | ??:??:?? 12 [EnvironmentTelemetryModule] serialized json message: {“channel”:0,“from”:2681572303,“id”:1605844695,“payload”:{“barometric_pressure”:0,“current”:0,“gas_resistance”:0,“relative_humidity”:

INFO | ??:??:?? 12 [EnvironmentTelemetryModule] JSON publish message to msh/US/2/json/LongFast/!9fd58bcf, 264 bytes: {“channel”:0,“from”:2681572303,“id”:1605844695,“payload”:{“barometric_pressure”:0,"curren

DEBUG | ??:??:?? 12 [EnvironmentTelemetryModule] Sending mqtt message on topic ‘msh/US/2/json/LongFast/!9fd58bcf’ to client for proxying to serve��@INFO | ??:??:?? 1

And then after that it says “Not Connected. Select a board and port to connect automatically.” And it does that over and over and over and over again

FYI the battery voltage was only like 4.2V or less.

Sorry, the log doesn’t help. We are not maintaining the Meshtastic firmware nor can we do support for it.

Remove all modules from the Base Board and test if it boots.
Then add the modules one by one and test each module.

If you flash a “normal” Arduino firmware, does the module work?

For a test of the hardware, can you flash the attached UF2 file?
It will run a test on the I2C bus and reports the devices available.
WisBlock_LowPower_V1.0.0_2024. (150.2 KB)

Unzip the file into a folder
Double push RESET button quickly
Drag the WisBlock_LowPower_V1.0.0_2024. file to the new RAk4631 drive that is showing up
Check the log output. It should look similar to this:

10:41:30.888 --> [APP] Setup application
10:41:31.011 --> [APP] Initialize application
10:41:31.011 --> [APP] Scan I2C bus
10:41:31.011 --> [SCAN] Found sensor at I2C1 0x42
10:41:31.393 --> [SCAN] Found sensor at I2C1 0x52
10:41:31.393 --> [SCAN] Found 2 I2C devices

I removed the one module I had on it, temp and humidity, it takes longer, but still same error message eventually. I will give this a try Device Firmware Upgrade | RAKwireless Documentation Center

Don’t use the firmware from that link. It is for a different firmware/bootloader and will fail.

Please try the test firmware I sent you first.


This is what I got
[APP] Setup application

[APP] Initialize application

[APP] Scan I2C bus

[SCAN] Found 0 I2C devices

Any modules plugged in?
Does it reboot or just stop there?
Can you try to send AT+VER=? over the USB to the device? It will show if the device is still working or if it is hanging.

No modules plugged in. it just stopped there.
From AT+VER=? I get this

AT+VER=WisBlock API 2.0.10


Ok, that’s good. The hardware is not hanging.

Now plug in the modules and retest.

Ok I plugged in RAK1901 and got this
[APP] Setup application

[APP] Initialize application

[APP] Scan I2C bus

[SCAN] Found sensor at I2C1 0x70

Ok, so you have a RAK1901 temperature and humidity sensor plugged in:

	{0x70, false}, //  4 ✔ RAK1901 temperature & humidity sensor

If this is a RAK1901, your hardware is working and not damaged. Then the problem is with the Meshtastic firmware. But for that I cannot help. You have to ask the Meshtastic guys.

yes that is what I have. Thanks for your help. Would the semtech radio be an I2C device?

Disregard. After flashing the meshtastic firmware it seems to be working now.THANKS!

The radio is an SPI device, not I2C.

Glad the kit is working again.

Have fun with WisBlock Meshtastic.