RAK4631 not connecting to Wis Toolbox

I’ve bought several RAK4631 with the Wisblock base. When I first plug in the USB I am able to connect. This worked for the first few times until it stopped working. I assumed I caused damage to the first board I purchased as I did not have the antenna connected. I purchased 2 more RAK4631’s and tested today. They connected the first time when I plugged it in via USB. I attempted to update the firmware which failed. I then attempted to connect over bluetooth which worked the first time. Again the firmware update failed. Now Wis toolbox does not recognize it and it won’t connect over bluetooth (blue light not flashing, solid green and solid red)

Are your RAK4631 flashed with the RUI3 firmware?
WisToolBox is for RUI3 devices. It does not work with RAK4631 that have the Arduino Bootloader.

Out of the box, the RAK4631 have the Arduino Bootloader and come with a test firmware that might partly work with WisToolBox and BLE.

After the failed firmware update, what are you seeing on the LED’s of the WisBlock Base Board?

Thanks Beegee. I followed the instruction to install RUI3 firmware and was able to connect to Wisblock and apply a template. The only light i have is a solid Red.

The default RUI3 firmware is a AT command based firmware. It does not control any of the LED’s.
When you connect over USB and a Serial Terminal (or WisToolBox terminal), send AT+VER=? and check what the response is.