RAK50005-O Sleep Mode

Hello, I am using RAK5005-O wisblock base board. I am using the “api.system.sleep.all()” function to sleep the card. The current it should draw in sleep mode is between 2-10 uA, but it draws 3 mA. What should I do?

How does the rest of your code look like?
Did you enable LoRaWAN auto join? If yes, is your device connecting to a LoRaWAN server.

If you enabled automatic join (AT command AT+JOIN=1:1) or you called api.lorawan.join() in your code, the Module cannot go into sleep mode as it is trying in the background to connect to a LoRaWAN server.


I just make these definitions and only advertise in the loop. Then I want the system to sleep for 2 minutes. AT+JOIN? I get the response AT+JOIN=0:0:8:0 to the command.

Do you have anything else plugged into the WisBlock Base Board? Where are you connecting your battery simulator?
3.3V is too low to supply correctly. The minimum battery voltage is 3.7V. Otherwise the step-down converter on the RAK5005-O will be in an unstable mode.

With your code I am getting an average of 22uA on my PPK2 when supplying 4V on the battery connector.

I’m experimenting with the power supply. I tried with 3.7V but the result still did not change. There are no components attached to the board.

The current has dropped to 12uA, but after reset, it draws about 3.5 mA for 20 seconds.

As you can see in the image from my PPK2, the BLE is automatically advertising for ~30 seconds after power-up/reboot. This is implemented to give the option to update with OTA DFU service even if the application is not setting up BLE by itself.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.