RAK5010 basic AT commands problems

Issue:AT commands malfunction on RAK5010 motherboard.

Setup:

Details:Hi,

I have a small project with RAK5010 that
I’m testing the server with a hologram SIM.

I have already tried to define the RAK5010 motherboard with AT commands, with more or less success.
Connects to DAP1 on UART port.
I uploaded the RUI v3.0.0.15 Firmware with DFU.

I control with the simplest AT commands that detect errors:

at + send = hologram: user: XXX
The entered message is not inserted in the message queue. Leave [MESSAGE_BODY] empty.

I successfully entered the device key with the at + set_config = hologram: XXX command. However, I do not know that I can change the TOPIC in the message with the AT command. Is there an AT command for this, or will it have to be defined in the code?

Here you can see that it executes the command at + send = hologram: sensor well, the message contains the sensor data. Here again, my question is how to rewrite TOPIC1?

Another error:
at + set_config = cellular: send_interval: X: Y
It does not execute the set value, but OK returns.
What should you do by default with this command?
Is it possible to set what should be the message to be executed or the last message, etc.? Sensor data sent to the hologram?
Do you have any idea what this might be wrong with?
Is there a setting option with AT commands?

I want to flash with Arduino next week, look at the materials, is there anything to look out for?
I want to write my own Firmware on it, what do you suggest for the simplest solution? RUI API, Arduino, other?
Amim has:
Arduino UNO Rev3
Arduino Nano
RAKDAPT1
RAK5010 and RAK5010-M

Thanks for the help.

Hi:
Joe

Welcome to RAK forum @JozsiKa ,

You have lots of question and mixing to one another so I’ll try to organize it a bit.

  1. I see that the data is sent to Hologram server. Do you want to change TOPIC1 or the format/arrangement of the data?
  2. Can you try at+set_config=cellular:send_interval:1:180000? You cannot use 150000, it should be more than that.
  3. The firmware of RAK5010 is based on RUI V2. It is here Products_practice_based_on_RUI_v2.0/based on RAK5010/RAK5010 at master · RAKWireless/Products_practice_based_on_RUI_v2.0 · GitHub. You can check at.c and you can see how the sensor data is formatted before sending to the Hologram server. RUI V2 is now deprecated. We are now going to release RUI V3 but compatibility with RAK5010 is still being develop.
  4. You can proceed using Arduino as well. This can give you more flexibility.

If you run at+set_config=cellular:send_interval:1:180000, you should be able to see the data every 3 minutes

Please do note that you need to restart the module via at+set_config=device:restart so that the interval will take effect. If the sleep routine is working, you should see that the LED are off. During this time, you will not be able to communicate to the module. The LED will blink again when it starts to transmit another sensor data. That is every 3 minutes if you set 180000.

Hi,

Yes, I want to change TOPIC1 and send a message with at + send = hologram: user: XXX, which is replaced by XXX and displayed on the Hologram page.
This is currently empty:

I’m going to try the interval setting, thanks.

You cannot change the TOPIC1 via AT command. You have to recompile a custom FW via RUI or do it via Arduino.

I am not sure why you don’t have a data.

Can you try to send at+send=hologram:user:test? You should see test and not an empty packet.

Hi,

I’ve done this before, for some reason he omits the text behind it. Be it anything, numbers, text, like “test”
There may be a unique error in the code, even though I made it at the factory.
If this is a bug in the code, where should I search and what should I look for?
What has been uploaded: RAK5010_dfu_20210223065027.zip

HI @JozsiKa ,

It seems you have the latest FW. Regarding your issue, I am not sure if it is a bug. It will be helpful if you can recall the sequences/steps you did before it went to send an empty packet. If you do the automatic transmissions, do you still receive the sensor data? Did you try setting the interval more than 150000?

Hi,

I’ve tried a lot of settings, I can’t really recall them all.
However, there were not many settings after the upgrade (DFU).
Will the update delete my settings and restore the factory settings on the BG96 as well?
Does the AT&F command reset the BG96 to factory settings?

Yes I tried a (1: 180000) setting and it works.
Sensor data is included in the message.

I tried e.g. that i can send a message with the at + send = cellular: XXX command.
Before that I set the required data:
AT+QICSGP=1,1,“hologram”,"","",1
AT+QIACT=1 (for this e.g. there was not always an OK answer)
AT+QIOPEN=1,0,“TCP”,“cloudsocket.hologram.io”,9999,0,1
na after that i tried in many different ways because the message could not be sent. By sending only this:AT+QISEND=0,38
Then when he came back> then the: {“k”:“XXXXXXXX”,“d”:“Test”,“t”:“TOPIC1”}
I also tried this:
AT+QISEND=0,38{“k”:“XXXXXXXX”,“d”:“Test”,“t”:“TOPIC1”}
unfortunately no message was saved. ERROR

I also tried to set up the BG96:
at+set_config=cellular:(AT+QCFG=“band”,F,80084,80084)
at+set_config=cellular:(AT+QCFG=“iotopmode”,2)
at+set_config=cellular:(AT+QCFG=“nwscanseq”,020301)
at+set_config=cellular:(AT+QCFG=“nwscanmode”,3)

It didn’t work either. After that, it had to be reset because the factory program didn’t work either.

An example:


| ___ / _ \ | | / / | | | () | |
| |
/ / /\ | |/ / | | | | _ __ | | ___ ___ ___
| /| _ || \ | |/| | | '
/ _ \ |/ _ / __/ __|
| |\ | | | || |\ \ \ /\ / | | | __/ | /_ _ \
_| __| |
/_| _/ / /||| _|_|_||//


RAK5010 Version:3.0.0.15


========================================================

at+version
at+version
Firmware Version: RUI v3.0.0.15
OK

at+set_config=cellular:(AT+QCFG=“band”,F,80084,80084)
AT+QCFG=“band”,F,80084,80084
OK>>at+set_config=cellular:(AT+QCFG=“iotopmode”,2)
AT+QCFG=“iotopmode”,2

OK>>at+set_config=cellular:(AT+QCFG=“nwscanseq”,020301)
AT+QCFG=“nwscanseq”,020301

OKStart scanning…

at+set_config=cellular:(AT+QCFG=“nwscanmode”,3)
AT+QCFG=“nwscanmode”,3

OK>>at+set_config=cellular:(AT+COPS=?)
AT+COPS=?

at+set_config=cellular:(AT+COPS=?)
AT+COPS=?AT+COPS=?
+COPS: (1,“Telenor HU”,“TelenorH”,“21601”,8),(2,“Telekom HU”,“THU”,“21630”,8),(1,“Telekom HU”,“THU”,“21630”,9),(1,“vodafone HU”,“voda HU”,“21670”,9),(0,1,2,3,4),(0,1,2)

OK>>at+set_config=cellular:(AT+QNWINFO)
AT+QNWINFO

+COPS: (1,“Telekom HU”,“THU”,“21630”,9),(1,“vodafone HU”,“voda HU”,“21670”,9),(0,1,2,3,4),(0,1,2)

OK>>at+set_config=cellular:(AT+QICSGP=1,1,“hologram”,"","",1)
AT+QICSGP=1,1,“hologram”,"","",1

OK>>at+set_config=cellular:(AT+QIACT=1)
AT+QIACT=1

OK>>at+set_config=cellular:(AT+QIOPEN=1,0,“TCP”,“cloudsocket.hologram.io”,9999,0,1)
AT+QIOPEN=1,0,“TCP”,“cloudsocket.hologram.io”,9999,0,1

OK

+QIOPEN: 0,0

at+set_config=cellular:(AT+QISEND=0,43)
AT+QISEND=0,45
+QIURC: “recv”,0,2
ok

+QIURC: “closed”,0

at+set_config=cellular:({“k”:“XXXXXXXX”,“d”:“HelloUzi”,“t”:“Proba”})
{“k”:“XXXXXXXX”,“d”:“HelloUzi”,“t”:“Proba”}
ERROR

The AT&F command will setup certain parameters but not all. The list is in BG96 AT Command Manual. It has a long list but it starts with this.

You and I have different ways on setting up the connection in hologram. Our AT Commands will execute the necessary commands. You just have to connect to your local cellular provider and input the Hologram device key then you should be able so send data directly.

The sequence of commands I use.

  • at+scan=cellular
  • at+set_config=cellular:(AT+COPS=0,0,“Globe Telecom-PH”,0)
  • at+set_config=cellular:(AT+QICSGP=1,1,“hologram”,"","",0)
  • at+set_config=hologram:s8zLgWat
  • at+send=hologram:user:test

Then I will see test on the payload.

Hello

Was the message tested successfully?
I tried another (virgin) motherboard this is a RAK5010-M.
Here again, the situation is that you omit the message entered in place of XXX in the generated message.

message entered:
at+send=hologram:user:HOPP

generated message queue:
AT+QISEND=0,36{“k”: “********”, “d”: “”, “t”: “TOPIC1”}

so an empty message goes away.

Thk.
JozsiKa

Hi @JozsiKa ,

Can you try the sequence above?

sorry, of course i will try in this order.
Unfortunately, the result is the same:

| ___ / _ \ | | / / | | | () | |
| |
/ / /\ | |/ / | | | | _ __ | | ___ ___ ___
| /| _ || \ | |/| | | '
/ _ \ |/ _ / __/ __|
| |\ | | | || |\ \ \ /\ / | | | __/ | /_ _ \
_| __| |
/_| _/ / /||| _|_|_||//


RAK5010 Version:3.0.0.15


========================================================
Start scanning…
AT+COPS=?AT+COPS=?
+COPS: (1,“Telenor HU”,“TelenorH”,“21601”,0),(1,“Telekom HU”,“THU”,“21630”,0),(1,“vodafone HU”,“voda HU”,“21670”,0),(1,“Telenor HU”,“TelenorH”,“21601”,8),(2,“Telekom HU”,“THU”,“21630”,8),(1,“Telekom HU”,“THU”,“21630”,9),(1,“vodafone HU”,“voda HU”,“21670”,9),(0,1,2,3,4),(0,1,2)

OKAT+COPS=0,0"Telekom HU",0

+COPS: (1,“Telenor HU”,“TelenorH”,“21601”,8),(1,“vodafone HU”,“voda HU”,“21670”,0),(1,“Telenor HU”,“TelenorH”,“21601”,0),(2,“Telekom HU”,“THU”,“21630”,8),(1,“Telekom HU”,“THU”,“21630”,0),(1,“Telekom HU”,“THU”,“21630”,9),(1,“vodafone HU”,“voda HU”,“21670”,9),(0,1,2,3,4),(0,1,2)

OKAT+QICSGP=1,1,“hologram”,"","",0

ERROR
˙˙˙˙˙˙˙˙˙˙˙˙
OK
˙˙˙˙˙˙˙˙˙˙˙˙˙˙˙˙˙˙˙˙˙˙˙˙˙˙˙˙˙AT+QICSGP=1,1,“hologram”,"","",1
OKat+set_config=hologram:********OK
AT+QIOPEN=1,0,“TCP”,“cloudsocket.hologram.io”,9999,0,1

OK

+QIOPEN: 0,0
AT+QISEND=0,36{“k”:"********",“d”:"",“t”:“TOPIC1”}

SEND OK

+QIURC: “recv”,0,5
[0,0]

+QIURC: “closed”,0
AT+QICLOSE=0,30000
OKat+send=hologram:user:testOK

The message goes and arrives at the hologram server, only empty.

As you see here, I can send it successfully.

I got some +QIOPEN: 0,561 errors earlier but it was solve by reuploading the FW via DFU BLE and changing the network provider. The automatic mode (at+set_config=cellular:send_interval:0:180000) is disabled right?

yes automatic mode is disabled.

it is clear that during automatic commands
a message leaves the (data) line blank.
+QIOPEN: 0,0
AT+QISEND=0,36{“k”:"********",“d”:"",“t”:“TOPIC1”}
This is what it should look like:
AT+QISEND=0,40{“k”:“xxxxxxxx”,“d”:“test”,“t”:“TOPIC1”}

I am still not sure why you are having issues. If you activated the automatic mode, this is the payload that you must have. Same with hologram:sensor command.

Errors on my side before was gone when I reuploaded the FW via BLE DFU. Then enabled-disabled the auto mode. Do you have success transmitting on auto mode? Or same situation with manual mode that the received payload is empty?

Other things I noticed.

  1. The quotation marks. This sometimes causes errors depending on the encoding of the serial terminal tool.
  2. You uses PAP authentication, I am not sure if that is needed.

I did the DFU firmware update again.
After that, I set up interval sending and successfully sent the sensor data. Then I deleted the interval command.
I tried to send the manual data again, but unfortunately the message goes blank.

I can see it working on your terminal.
Although the message details are not visible in the serial communication:
AT + QISEND = 0, etc. ?
Reconcile the differences in serial communication.
What I use:
RAK SERIAL PORT TOOL
USD-RAKDAPT1-UART-RAK5010

i tried the same with a new RAK5010-M motherboard where it also omits the (data) text from the message. I didn’t set anything on it except the required cellular settings. There was no DFU firmware replacement on it either.