RAK5010 BG96 Troubles

I have a custom application running on a RAK5010 and have a couple dozen devices out in the field that are functional. What I’m experiencing is that a device will no longer be able to connect to the cellular network.

I have a device that was running for over 3 days that just stopped connecting to cellular. I booted it into debug mode where have have a AT console and tried to manually connect.

AT+COPS=? returns a list of possible operators, but no matter which one I select I get ERROR 30.

I’ve tried with a couple different SIMs and have tried various Antennas (signal on all are really good).

So I don’t know where to look. Could this be an issue on the network side? I changed SIMs but is there an ID of the device that might be getting block regardless of SIM?

Is it possible that this RAK5010 has failed for some reason? (I have 4 devices over the last few months all have the same issue).

I’ve tried different power - USB, Battery, combination, etc. I’ve rebooted numerous times.

I need to find out where to look and a solution to this. I’m not sure if it is at the SIM provider side (Telnyx) or if its local operators (AT&T and T-Mobile) or if it’s Hardware (RAK5010 or BG96).

Any advice?

Thanks in advance.

Hi @InlineTechnology ,

It seems to be related to the network. Do you have devices that still work or all have problems now?

Are you using eMTC(LTE-M), nb-iot or egprs? Can you switch like from LTE-M to EGPRS if still supported on your area?

Can you try to update the firmware of RAK5010 to have a fresh start? RAKwireless Downloads

I’m running a custom firmware (Arduino) w/ my software. But I can also just install a AT debug session and type commands in to send directly to the BG96.

18:44:31.060 → AT+CFUN=1
18:44:32.696 → OK

18:44:38.575 → AT+COPS=?
18:45:17.943 → +COPS: (2,“T-Mobile”,“T-Mobile”,“310260”,8),(1,“313 100”,“313 100”,“313100”,8),(1,“311 490”,“311 490”,“311490”,8),(1,“AT&T”,“AT&T”,“310410”,8),(1,“Verizon”,“Verizon”,“311480”,8),(0,1,2,3,4),(0,1,2)
18:45:17.943 → OK

18:46:51.521 → AT+COPS=1,0,“AT&T”,8
18:47:26.769 → +CME ERROR: 30

This is only happening w/ a few devices. But it has happened to a device that was in the field where connectivity just stopped.

Thinking it’s network, but I need to find a way to prove where the issue is. I just ordered SIMs from another company.

Additional information - this is odd…

22:49:12.980 → AT+CFUN?
22:49:12.980 → +CFUN: 1
22:49:12.980 → OK

22:49:18.279 → AT+COPS=?
22:49:29.201 → +COPS: (1,“Verizon”,“Verizon”,“311480”,8),(1,“313 100”,“313 100”,“313100”,8),(1,“AT&T”,“AT&T”,“310410”,8),(2,“T-Mobile”,“T-Mobile”,“310260”,8),(1,“311 490”,“311 490”,“311490”,8),(0,1,2,3,4),(0,1,2)
22:49:29.201 → OK

22:50:06.253 → AT+COPS=1,0,“AT&T”,8
22:50:14.094 → +CME ERROR: 30

22:50:27.316 → AT+COPS=1,2,“310410”,8
22:50:27.731 → +CME ERROR: 30

22:51:00.862 → AT+COPS=2
22:51:00.862 → OK

22:51:08.616 → AT+COPS=1,0,“AT&T”,8
22:51:16.397 → +CME ERROR: 30

22:51:32.773 → AT+COPS=1,2,“310410”,8
22:51:33.971 → OK

22:51:58.410 → AT+COPS?
22:51:58.410 → +COPS: 1,2,“310410”,8
22:51:58.410 → OK

22:52:33.623 → AT+QENG=“servingcell”
22:52:33.623 → +QENG: “servingcell”,“NOCONN”,“CAT-M”,“FDD”,310,410,29B0911,380,5110,12,3,3,5304,-91,-9,-65,12,32
22:52:33.669 →
22:52:33.669 → OK

What’s odd about it is that
AT+COPS=1,0,“AT&T”,8 and

should be the same record. But, selecting Operator by Numeric operator number seems to work, but select by “AT&T” does not.


Looking at your AT+COPS? You have lots of available network and the SIM card you are using seems to work on all those network. Is that normal on your location? Here in my country, we have only two operators that’s why the other is restricted if the SIM card is not from that network provider.

+COPS: (2,“SMART Prepaid”,“SMART Pr”,“51503”,0),(3,“Globe Telecom-PH”,“GLOBE”,“51502”,0),(0,1,2,3,4),(0,1,2)

On my AT+COPS, I use at+set_config=cellular:(AT+COPS=0,0,“SMART Prepaid”,0). That is automatic mode but still, I write the operator name. Probably you can try automatic mode so your SIM will try to connect to the compatible network. (Honestly, I am not sure if this makes sense but this works for me all the time)

To isolate the issue, if possible, you can swap one working unit to the non-working unit. Then if it works, then less likely that it is the network.

This part is really strange. Probably it is good to consult our friends from Quectel why. They also have a forum in the same format like RAK forum and I also post issues there.


Btw, can you share the sequence of commands that works for you? Since you are not using the default FW, your commands might be different from ours.