RAK5010 Can't connect to network

Issue: Can’t get the correct CREG and CGREG to connect to network

Setup: RAK5010 V2.0 connects to PC using USB cable. The command is accessed via Termite.

Details: When I can’t connect to the network. When I check the network, this is what I got:





+COPS: 0

+CEREG: 0,0


+CREG: 0,0

+CGREG: 0,4

The SIM Card is active and I tried it in my cellphone and it worked perfectly.
I take a picture of my setup. Please take a look and tell me what I got wrong with my setup.

Thank you.
Best regards,

Welcome to RAK forum @rtsetiabekti ,

Can you please check the version of the FW using at+version?

Also, can you try to use at+scan=cellular command? You have to wait for a while before the list of network shows.

I am finally able to connect to network by changing this


However, the result connection is EDGE. I suspect the APN should be LTE APN, right? Or is there anything I need to set?
Also, is it important to get AT+CEREG: 0,5? Because no matter how hard I tried, the result is always 0,4; despite CREG and CGREG is both 0,1.

Thank you.
Best regards,

Hi @carlrowan,
Thanks for your reply.

Firmware Version: RUI v3.0.0.15

+COPS: (2,“3-SinyalKuatLuas”,“3-Sinyal”,“51089”,0),(3,“IND TELKOMSEL”,“T-SEL”,“51010”,0),(3,“IND INDOSAT”,“INDOSAT”,“51001”,0),(0,1,2,3,4),(0,1,2)

Those are the output from the command you suggested.

Thank you.
Best regards,

On the list, on what network are you trying to connect?

Hi @rtsetiabekti ,

The Quectel module in RAK5010 supports EGPRS, LTE-M (not LTE) and NB-IoT. I am not sure what you mean with LTE APN but if your cellular provider still supports GPRS, you can connect the RAK5010 to that. You can ask them for the right APN. In my case, the local cellular network uses same APN for GPRS and LTE (as far as I understand). No special LTE APN.

I changed the SIM Card and this is the output I get from running at+scan=cellular

+COPS: (2,“Tsel-PakaiMasker”,“Tsel-Pak”,“51010”,0),(1,“IND INDOSAT”,“INDOSAT”,“51001”,0),(1,“3”,“3”,“51089”,0),(1,“510 11”,“510 11”,“51011”,0),(0,1,2,3,4),(0,1,2)

I also run at+set_config=cellular:(AT+COPS?) and I get this:

+COPS: 0,0,“Tsel-PakaiMasker”,0

And yes, this is the network I want to connect to.
If I run at+set_config=cellular:(AT+QNWINFO), the output I get:

+QNWINFO: “EDGE”,“51010”,“GSM 1800”,782

I want to connect to “CAT-NB1” “LTE BAND”

Thank you.
Best regards,

Hi @rtsetiabekti ,

I don’t think there is LTE-M and NB-IoT service available in your area.


If you look on the scan, all are zero value which measn you can only connect via EGPRS. It should be either 8 or 9 to connect to LTE-M or NB-IoT.

Maybe you can confirm in your telco provider.