Rak5010 newbee - timeouts

Issue:timing out, lack of reponse

Setup:RAK5010 usb and uart working with Windows 10

Details: Easter Greetings to all.
I have started playing with a couple of RAK5010 modules, connected by UART and USB. I have some questions that I hope some can answer.

  1. The modules seems to work on power up but after some time seems to lock me out of AT commands - I seem to remember reading somewhere that there may be a AT command lock out time. any suggestions ideas
  2. The RAK SERIAL PORT TOOL will sometime locks up and I need to task manager - kill, is this a reliable tool?
  3. There seems to be a shell over the AT commands - having to use
    at+set_config=cellular:(AT+XXXX) all the time. Can this be changed so I do the AT commands only ( only a small inconvenience - mainly a question)
  4. Sometime when I do a at+set_config=cellular:(AT+COPS?), I get no response - I’ll do a at+version to see if its still there and I will get the response form the COPS command, it then seem to get out of sequence, I do a AT+CREG? and I’ll get the version info. Is this me simply being too impatient and getting ahead of my self ?? If so how do you regulate the command/response routine ? There doesn’t seem to be an acknowledgment that a command has been sent - or that its being processed for long commands like COPS?

Any help would be appreciated.

It seems the module stops responding to AT commands about 12-13mins after startup
If I run a command eg at+set_config=cellular:(AT+CCLK?) every second (or every 10 secs - doesn’t make a diff.) the RAk5010 will not respond to the command after the 12:40min mark.
I have to powered down and restart to regain control.

Welcome to RAK forum @leotec :slight_smile:

  1. Can you please explain more the AT command lock out experience you have? Does it mean you input a command but no reply? If yes, what command is that and what is the command you sent previously before that.

  2. RAK SERIAL PORT TOOL is stable SW. But if you suddenly remove the device, then that is the possible reason why it crashes.

  3. There is no work around here. This is the only way because you are not communicating directly to the BG96 but to the NRF52840 MCU first.

  4. AT+COPS? takes a long time to get a reply. Unfortunately, there is no reply on AT+COPS is being process. This is a default behavior of BG96.

Thanks for the reply
It doesn’t seem to matter what AT command!!
One example is sending
at+set_config=cellular:(AT+CCLK?) every 10 seconds or so
The first 60-70 times it works then the unit stops responding. The blue light stays on, the red continues to flash. I also tried CREG and at+version , after about 12-13 mins (some times earlier) it stops .
This happens on two units I purchases. I am using a USB power pack to supply the power by the usb and use the RAK serial tool to monitor .
Does the 3.3v link between the serial tool and the RAK provide power to the RAK5010 or vise versa ?
Thanks again

Further to my problem. I took out the SIM and retried the example, sending CCLK every second. The unit locked up at 11min27secs. AT+CCLK? +CCLK: “80/01/06,00:11:27+40” OK
Using the NRF RESET KEY (BUTTON) will bring it back to life via UART

tested again - 9 mins then locks up
This time use the PWR KEY (button) will NOT re-establish connection via UART , but the NRF RESET does.
version is RAK5010 Version:

Hi @leotec , do I understand it correctly that you do not have a battery connected? If that is the case, that could probably causing the problem of sudden halting of your RAK5010. Please connect a LiPo battery or the common 18650 Li-Ion battery the try testing the module again. There is a big chance that’s the one causing the problem :+1:

Hi carlrowan
Thanks for the continued support. I do have a battery installed and it has enough capacity to run the RAK5010 independant of the USB -
+CBC: 0,99,4189 even whilst make data transfers, however after a time both RAK5010 units still hang up.
I have now configured them with a hollgram card and can make connections.
but struggle with the timeout (or what ever causes the disconnection)
I am ultimately connecting the RAk5010 into a vehicle for monitoring.
How do you suggest I power the units in this case - as I have a constant high current 12 or 24 DC power supply and can provide 5VDC 2A - would I bring that in on the DC solar input or bring it in at 1.8V on VDD JP9 pin 1)

Hi carlrowan,
I have been trying everything to try and understand why the units ignore the commands after some time
I have been looking at

Firstly it seems the wrong way
at+set_config=device:sleep:0 stays awake
at+set_config=device:sleep:1 sends it to sleep
conflicting with the documentation.

If I at+set_config=device:sleep:0 it acts the same way as the unit does when I loose control ??
Is my module going to sleep after 12-13 mins ??
How do you wake it up form the UART ??

Sorry - not exactly the same , when I issue the sleep - it looses the blue and red leds.
When the unit starts to ignore the commands the leds remain BLUE on - RED Idle mode and doesn;t respond.

Hi @leotec ,

It’s likely that battery or good power source is the cause of your problem but it seems you already checked it.

For your power supply 5Vdc 2A to DC solar input is ok. Do not feed it to 1.8v because the module already has a regulator.

The parameter of sleep is incorrect. I will update it.

May I know the sequence of commands you are trying?

Do you follow the steps on our quick start guide https://docs.rakwireless.com/Product-Categories/WisTrio/RAK5010/Quickstart/#prerequisites?

Hi carlrowan,
OK - quite convinced it not power related. I believe its DTR related.
I find I can reliably talk to the RAK5010 without timeouts if I use the USB interface and Termite, but cannot stay connected if I use the RAK SERIAL TOOL or other serial tools on USB.
I monitored the RTS & DTR states with Device Monitor Studio and find that if the DTR line is held high (default by Termite) then is won’t time out.

If I talk to the RAK5010 via the UART connection ( by any terminal emulator) then there is not DTR RTS connection and the units stops after some time under any serial terminal.
Is there a DTR connection I should be using on the UART ??
What about full details on the RAK serial tool - nanoDAP V2.3 ??

I intend to use a microchip to talk to the RAK5010 via the UART - is there a DTR setup I’m missing ??

is the DTR setup only used for the RAK NRF communications, if I change the unit to direct BG96 will I need the DTR ??

I see.

I am using using Coolterm as serial terminal in macOS to communicate with RAK5010. DTR must be enabled.

If you go direct to BG96, DTR is not needed.

Thanks again
So I have determined that the connection via the UART acts the same as the USB without a DTR signal, it stops responding to commands after some time . Sometimes just a few at commands other times as long as 13 mins
Iß there a DTR for the UART connection ?

What do you mean?

Btw, RAK5010 USB is USB CDC and not physical uart lines.