RAK5010 unable to connect to nrf connect mobile

Issue: Unable to connect RAK5010 to nrf connect mobile app over bluetooth

Setup: RAK5010 based on RUI, IOS14.7, nrf connect 2.4.12

Details: The RAK5010 device shows up on the nrf connect app as RUIxxxxx. When I try to connect to the device through the app via bluetooth the it only shows connecting and does not actually connect to the RAK5010. When viewing from the RAK5010 via RTT Viewer it goes back and forth from being connected and disconnected. I am attepting to connect in order to be able to do an OTA update via bluetooth. I have used both custom firmware based on RUI as well as the premade firmware from https://downloads.rakwireless.com/Cellular/RAK5010/Firmware/ from the app it shows the strength of the connection from RAK5010 and then shows no signal from the RAK5010.

Welcome to RAK forum @twilson :slight_smile:

I am not sure what’s happening but if the module is connecting and disconnecting, it can be the power source. Are you using USB only? Can you try to add a battery in it?

Also, is there a possibility that you try a different phone since it is a connectivity issue? Just for sanity check that it is not a phone related bluetooth issue.

Thank you!

I was initially just using USB, however adding the battery did not fix the issue or change anything.

I did also try another phone, also IOS. That was also unable to connect to the RAK5010 and showed the same results.

Any other idea to why it may not be connecting?

Here is what I’m seeing from RTT Viewer

What I see first from nrf connect:

What I see about 1 second later:

While I have a post open I did have another question. Is it possible to scan and list all nearby bluetooth devices with rui? If it is possible how would I go about doing that?

Hi @twilson ,

What are the status of the LEDs in RAK5010 while you are trying to connect? I tested mine here and it connects ok.

On scanning BLE devices, you can use this API RUI BLE General Format | RAKwireless Documentation Center

We do not have specific example for RAK5010 for your requirements but you can have a look on this example code for RAK4600 that seems to be the code you are looking. This is also based in RUI Products_practice_based_on_RUI_v2.0/based on RAK4600/BLE/BLE_Scanner at master · RAKWireless/Products_practice_based_on_RUI_v2.0 · GitHub

The LEDs stay the same whether I’m trying to connect or not. The left LED is always on blue and the right LED blinks red every 2 seconds.

Thank you for that example code, it looks like exactly what I’m looking for!

Hi @carlrowan ,

Any other ideas to what could be causing this? I’m not sure if the LEDs give you any better idea of what could be happening.

I checked the status of the LED to see if the device goes to sleep. It seems not if you say that it is always on indefinitely (with battery only).

Have tried loading a different FW now?

Yes I have used the precompiled firmware for rui version and version as well as some custom firmware that I made also based on rui

Few things we can still try:

  1. Try to connect to Android phone instead of IOS. You can also try to use bluetooth serial terminal application in Android to connect to it.
  2. Check other RAK5010 board just to validate that it is not a phone issue (if you have extra).
  3. Check current consumption by using an external power supply because it might be too high or unusual.
  4. Upload an Arduino bootloader to the NRF52840 and test the bluetooth using bluefruit library or other BLE libraries to test the Bluetooth functionality.

I hope we can find something by trying these things. Otherwise, I am afraid I am exhausted with ideas what else to do.


I am not sure I can try the other options right now but I was able to upload the Arduino bootloader from here: https://forum.rakwireless.com/t/arduino-on-rak5010/1175 using that and the included demo project from that I was able to connect to the rak5010 using the nrf connect app. I then tried to go back to using the RUI firmware made by me and still the same outcome as before. Any idea why using RUI would not allow me to connect to nrf connect?

Hi @carlrowan ,

Any other ideas to why I am able to connect to nrf connect when using the RAK with Arduino but I am not able to connect to nrf connect when using the RAK with the RUI api?

Hi @twilson
Sorry for jumping into this discussion.
I am having problems with nrfConnect on Android as well from time to time. If you just want to connect to the BLE Uart service and you are using Android, you can try My nRF52 Toolbox or Serial Bluetooth Terminal. Both worked better for me.

1 Like

Hi @carlrowan ,

After finally being able to test using an android device I was able to get the RAK5010 to connect with nrf connect and then able to push an update using bluetooth. So the issue must be something with the IOS app.

Good news @twilson .

I am an apple product user too. But when it comes to engineering stuff, I feel things must be confirmed to windows (if using macOS) or android (if using iOS) when things are not working well. That’s why that is my #1 suggestion :sweat_smile:

Good luck on your project!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.