RAK5202 Not responding

Issue: Board is not responding

Setup: RAK5202


Details: Hey, I tried to send any command but I get no response:

After that I tried to format the board with the RAK upgrade but it failed. So I tried to download firmware to the board but I keep getting this error:

I checked even with STM32programmer but still:

The last thing that I tired is to reset the bootloader with the reset button but I get nothing back:

You can see that there is a red led turned on and that I connected the boot jumper.

The computer recognize the board:

What else can I do to fix that?

Hi @ophirg123
Can you try once again the STM32 Programmer? Close all other applications that may use the serial port (RAK serial tool etc) and with boot jumper on the pins and USB connected to the PC press the reset button of the board. Then open STM32 programmer and try to connect.

Hey, I tried again and I get the same… no respond

I have ST-LINK V2 if it can help for something.

Hey there are any news?