RAK5205 do not respond on UART


I’m still on my project to send data threw the RAK5205 and I was devlopping with the RUI Online Compiler but since today and the last upload on the module with the RAK Upgrading Tool, it do not repond anymore in anyway. First of all I can’t flash the firmware with this software, I have to use STMFlash Loader Demo, and even when the flash is successfull (even with the original updated firmware), I can’t interract with the module… I tried a lot of things but it already happened with an other module, the RAK811 trackerboard and I didn’t find the solution neither.
I am completely stuck now and if someone can help me it would be fantastic…

Can you try to upload these FW?

If you are using US915, EU868, other higher freq - H_FW
If you are using EU433, CN470, other lower freq - L_FW

Please upload the .hex file and not the .bin file then let me know that result.

You need to use STM32CubeProgrammer.

You can follow this guide RAK5205 Quick Start Guide | RAKwireless Documentation Center

1 Like

It worked, thank you !!!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.