RAK5205 dont response

Hey everyone,

I have 2 boards of RAK5205 and I need to add some functions to the P2P communication.

I tried to compile the files (without modify any of them) in the page of products practice based on RUI:

I succeeded to compile and got the BIN file. I loaded it to the board and i tried to sent at commands with rak serial port tool but i didn’t get any response.

Then I tried to load the offical firmware RUI_RAK5205_V3.0.0.12.L.T1_Release.bin but even then I didn’t get any response.

I had to connect my other RAK5205 and to upload the firmware of him to my pc. Then I loaded it again to the one that I tried to modify and then I got response.

I check the sizes of the 3 files that I checked:

I hope you will be able to help me.

Did you upgrade with reference to this? It must keep the board loaded with BootLoader, if not, please refer to the previous section.

Ohh I looked in the manual and I used the other guide for burning firmware. Thanks, it worked!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.