RAK5205 Exit boot mode

How to exit Boot mode? According to the docs, the command is: at+run but it doesn’t work

Hi @Ori,

Yes, at+run is used to exit the boot mode.
Which version firmware are you using? Or can you share me some logs to show what happens?

We’ve confirmed again, and at+run can exit the boot mode successfully as the following picture shows:

Please try again.
If it still don’t work, maybe your RAK5205 has only bootloader, no application firmware in it. You can download the firmware from RAK website:
‘H’ means high frequency, for example, EU868, US915, etc.
‘L’ means low frequency, including EU433 and CN470.

You can flash the above firmware according to the section 3 of this document:

Yes it was apparently only running the boot loader. Still its confusing because when I run at+version it did say so I assumed it came flashed.


Hi @Ori,

You can reflash the firmware according to the document i share on the above.

I tried it on another device, same thing. I made sure I flash it with the firmware and it still doesn’t want to come out of boot mode with the command at+run.

Hi @Ori,

Can’t you just remove the jumper ?


I removed it :slight_smile: that’s not the problem.

Hi @Ori
Please assure that you make this steps:

  1. With jumper on boot pins - erase all from chip and flash bootloader with STM32Cube Programmer.
  2. Unplug from USB and remove boot jumper.
  3. Connect to USB and flash the firmware with RAK LoRaButton Upgrade Tool.
  4. When flash process is finished, restart device with reset button and connect with RAK serial tool .
    When connected with RAK serial tool and press restart button on device you should be able to see initialize serial output. If not please share print screen of serial output.

Todor Velev