RAK5205 Firmware doesn't join using AU915

I configured my RAK5205 using AU915 region and when it sends the “join request” the server responds “join accept” but the end device doesn’t catch it!

My configuration:


When I use firmware version 1.1.6 it works fine!

P.S: Where I can find the old firmwares (1.x.x)??


Hi @dhinojosac. Sorry to hear that you have troubles. Please flash the latest firmware from RAK5205 Git and try again. Share what is the result.


We have uploaded the latest firmware,Please flash the latest firmware from RAK5205 Git and try again.Next you need to do the following steps to configure the connection channel,%E5%BE%AE%E4%BF%A1%E5%9B%BE%E7%89%87_20190513103213
After that, you only need to restart the node to make the connection.

Which? RAK811_LF_trackerboard_V2.1.1.9.bin? LF is low frecuency?


Which one? RAK811_LF_trackerboard_V2.1.1.9.bin? LF is low frecuency?


I’m very sorry, some small episodes just appeared, now it has been uploaded and you can see the firmware of version

@Nicholas , I got this using the version. Where can I find the documentation of the AT commands?

Despite not being able to enter the mask for all channels, the node successfully joined.

I have modified it according to your configuration. The default frequency band of the firmware is EU868. When using EU868 frequency band, there are only 16 channels in its protocol.

The at command is available for your reference AT command1 and
AT command2

hi everybody…i have some problems with visualization of correct channels on AU915…with a “at+get_config=ch_list” command; it visualized only US915 channels; maybe it was for my node were configured early in US915 ?

You can do the following, then restart the hardware and look at the list.

thanks nicholas! in my case, the showed information was incorrect but the device work perfect; I assume that the mask is aplicated but, when you send the channel list command it show other channels like this capture: load a new firmware… send the command for AU915…and look this:

You tried to send the command:at+band=AU915, and then looked at the list again. I found from your diagram that the frequency band you set is EU868, probably because of this reason, you tried to modify the frequency band to pass the above command.

Mobile: +86 18146804729|E-mail:[email protected]| QQ1165798730

深圳市瑞科慧联科技有限公司 Shenzhen RAKwireless Technology Co.,Ltd.
Website: www.rakwireless.com | 微信公众号/官方微博:RAK瑞科慧联
Twitter: @RAKwireless | YouTube:RAK YouTube Channel