RAK5205 GPS is not working: FAIL.The Satellite signal not found!

Issue:RAK5205 GPS is not working

Setup: Firmware Version: RUI v3.0.0.12.H.T1

Details:
Hello, I need help and / or support.

I have bought a RAK5205 module a few months ago. I have recently tried to use it but find that the GPS is not working. This can be seen in the following copy of the RAK serial port tool:

OK
Start Search Satellite(about 300 seconds) …
FAIL.The Satellite signal not found!
*Battery Voltage = 4.193 V *
BME680 sensor data:

  • Humidity:39.89 %RH*
  • Temperature:32.94 degree*
  • Pressure:852.63 hPa*
  • Gas_resistance: 23481 ohms *
    LIS3DH sensor data:ACC_X: 86mg, ACC_Y: -74mg, ACC_Z: -1008mg

[LoRa]: send out
[LoRa]: RUI_MCPS_UNCONFIRMED send success
OK

I have configured the GPS with the following instruction to avoid sleep mode:
at + set_config = lora: send_interval: 2: 60

On the other hand, reviewing the schematic diagram I find that some components are apparently not installed, for example: C52, L2
You can also see the poor technique of the soldering of the antenna connectors!

See attached image for reference.

Dear,

This is unfortunate, but welding does not affect GPS searching.

You must connect GPS antenna and place in an open place.

try again!

Thank you.
What about this:
…On the other hand, reviewing the schematic diagram I find that some components are apparently not installed, for example: C52, L2

I have left the module for a long time, with the GPS antenna connected and placed outside, however I cannot get the module to get GPS data.

Dear,

Are you sure you haven’t welded yourself?

Of course not, but I am going to re-solder the antenna connectors, I can assure you that I will do a better job!
By the way, don’t you tell me anything about the connectors I mentioned that could be missing?

I see that the diagram shows nothing connected in C58! but there is a component! Is it possible that the factory put the L2 in the wrong place? (small red picture box)

Dear @fboesche

Can you send me the bar code on this board?
We will Inquiry it!
By the way,It is not welded in the wrong position, if there is no inductance, GPS will have no point quantity, which may be the problem.

Here is:
SN: 8262001820400025
DevEUI:60C5A8FFFE76013D

Dear @fboesche,

Thank you for your information!
If you have inductance,it will very perfect.

I have not, but will try to get one.
Should it be the exact value noted in the diagram?

Dear @fboesche
Yes!
But I just checked the test log. The GPS of this board is the normal test before the factory, so I can send you the test log.
Maybe you can check the GPS with the command:at+get_config=device:status

Response to >>at+get_config=device:status

at+version
at+version
Firmware Version: RUI v3.0.0.12.H.T1
OK

at+get_config=device:status
at+get_config=device:status
OK.


===============Device Status List================
Board Core: RAK811
MCU: STM32L151CB_A
LoRa chip: SX1276

Battery Voltage:4.193 V

gps_timeout: 300s
gps_format:GPS take six decimal places
GPS data:
No signal with Satellite.

LIS3DH sensor data:ACC_X: 97mg, ACC_Y: -73mg, ACC_Z: -1012mg

BME680 sensor data:
Humidity:64.375 %RH
Temperature:24.77 degree
Pressure:855.76 hPa
Gas_resistance: 8268 ohms
===================List End======================


OTAA Join Start…
[LoRa]:Join Success
OK
Start Search Satellite(about 300 seconds) …
FAIL.The Satellite signal not found!
Battery Voltage = 4.130 V

Nicholas, I don’t have to enter into contradictions with you, much less lie to you. Definitely the factory sent me a faulty board (without the L2 component installed!). I have installed an inductor that I found from another GPS module and now it works fine.
Being a new module, to be honest with you, I expected that RAKwireless, without objection, would take action to replace it, as appropriate. In the end I have made the module work and I will be able to do the tests for which I have bought it, but under the circumstances I will have to seriously consider if RAKwireless is one of my best options for future projects.
Thank you

Dear @fboesche

I just want to find the problem and solved it.Beacuse we are in different country,It is very troublesome to returned to the factory repair the products .
I ask you to confirm whether the welding is just to find out the problem.This is probably where I made a mistake.

Best regards!

Well, tell me what’s next?
Now that I have installed the component that was missing from the factory, the GPS works fine.

Regards

Dear @fboesche,

Now you can use it to complete your projects!

If there is any problem, I will help!

Best regards! :grinning: